Opened 10 years ago

Closed 9 years ago

Last modified 9 years ago

#11830 closed Bug (fixed)

Builder Ignores Plugin

Reported by: bmulholland Owned by: Artur Delura
Priority: Normal Milestone: CKEditor 4.4.2
Component: Project : CKBuilder Version:
Keywords: Cc:


Hi, I have a build-config.js that includes plugins like autogrow and sourcearea. However, when I run (locally or via the website) those plugins are not included.

Here's a filtered git diff after the update:

deleted: vendor/assets/javascripts/ckeditor/plugins/autogrow/plugin.js deleted: vendor/assets/javascripts/ckeditor/plugins/contextmenu/plugin.js deleted: vendor/assets/javascripts/ckeditor/plugins/floatpanel/plugin.js deleted: vendor/assets/javascripts/ckeditor/plugins/font/plugin.js deleted: vendor/assets/javascripts/ckeditor/plugins/format/plugin.js deleted: vendor/assets/javascripts/ckeditor/plugins/indent/plugin.js deleted: vendor/assets/javascripts/ckeditor/plugins/indentblock/plugin.js deleted: vendor/assets/javascripts/ckeditor/plugins/indentlist/plugin.js deleted: vendor/assets/javascripts/ckeditor/plugins/justify/plugin.js deleted: vendor/assets/javascripts/ckeditor/plugins/lineutils/plugin.js deleted: vendor/assets/javascripts/ckeditor/plugins/listblock/plugin.js deleted: vendor/assets/javascripts/ckeditor/plugins/magicline/plugin.js deleted: vendor/assets/javascripts/ckeditor/plugins/menu/plugin.js deleted: vendor/assets/javascripts/ckeditor/plugins/panel/plugin.js deleted: vendor/assets/javascripts/ckeditor/plugins/pastefromword/plugin.js deleted: vendor/assets/javascripts/ckeditor/plugins/removeformat/plugin.js deleted: vendor/assets/javascripts/ckeditor/plugins/richcombo/plugin.js deleted: vendor/assets/javascripts/ckeditor/plugins/sourcearea/plugin.js deleted: vendor/assets/javascripts/ckeditor/plugins/table/plugin.js deleted: vendor/assets/javascripts/ckeditor/plugins/tabletools/plugin.js deleted: vendor/assets/javascripts/ckeditor/plugins/widget/plugin.js

Attachments (1)

ckeditor-build-config.js (1.2 KB) - added by bmulholland 10 years ago.
build config

Download all attachments as: .zip

Change History (17)

Changed 10 years ago by bmulholland

Attachment: ckeditor-build-config.js added

build config

comment:1 Changed 10 years ago by bmulholland

Component: GeneralProject : CKBuilder

comment:2 Changed 10 years ago by Piotrek Koszuliński

Keywords: builder plugins removed
Resolution: invalid
Status: newclosed
Version: 4.3.4

Those plugins are merged into ckeditor.js. If plugin has no other files than plugin.js, then entire directory is removed. That's what building means - it combines as much files together.

comment:3 Changed 10 years ago by bmulholland

Oh cool! Does that mean that I don't need to include them in extraPlugins anymore? Do I need to include them in extraPlugins if there are extra files (and hence a directory)? Where could I find more information on this subject?

Thanks Reinmar!

comment:4 Changed 10 years ago by Piotrek Koszuliński

All plugins that are specified in build config are enabled by default, so you don't need to specify them in extraPlugins. I cannot find it explained clearly in the documentation, perhaps because it's easily verifiable. However, you may find some information here!/guide/dev_build

comment:5 Changed 10 years ago by bmulholland

Turns out that autogrow was NOT included in the ckeditor.js. Unfortunately it took a production deploy before we figured that out, and functionality that required it stopped working.

All other plugins were included but autogrow certainly was not. Any idea why this might have happened?

comment:6 Changed 10 years ago by Piotrek Koszuliński

Do you mean that you built a CKEditor package from the build config which you attached using command line builder and there's no autogrow plugin included in the package? How do you verify whether autogrow is included? Did you use repo or

comment:7 Changed 10 years ago by bmulholland

Hi Reinmar,

Thanks for replying.

I used ckeditor-dev, release/4.3.x branch.

My build config was as attached to this ticket, which includes autogrow.

I know autogrow wasn't included because the editor did not autogrow. It started as a fixed size and did not expand past that initial fixed size. Downloading autogrow as a separate plugin and adding it to extraPlugins corrected the behaviour so that the editor expanded to the appropriate height, as expected.

I also tried searching the generated ckeditor.js for the string "autogrow" with no results.

Thanks again, Brendan

comment:8 Changed 10 years ago by Piotrek Koszuliński

I downloaded your build config into the dev/builder/build-config.js, built package, opened first sample and autogrow was enabled and was working. Without extraPlugins usage, without downloading plugin.

comment:9 Changed 10 years ago by bmulholland

Okay, I have figured it out. To reproduce this issue, *specify the -s flag*.

Although the documentation says the following:


exclude from release all plugins/skins that are not specified in build-config

It appears to NOT include the autogrow plugin even if it's specified in the build-config.

comment:10 Changed 10 years ago by Piotrek Koszuliński

I'm sorry, but no luck. I used this flag and still autogrow is included. Are you sure that builder loads correct build config? Maybe it loads the build-config.js file, as does by default, and your has a different name? Note that passing --build-config to will not work, because always uses build-config.js.

comment:11 Changed 10 years ago by Jakub Ś

I have also test this and got same results as @Reinmar.

comment:12 Changed 10 years ago by bmulholland

Reinmar, that was it! It was using the build-config.js in the directory and completely ignoring my passed in build-config argument.

That seems like a bug in the documentation to me, and a very frustrating one at that. The help message should not reflect an argument that has no effect! I don't know how on earth I would have figured it out without you mentioning it as an aside.

comment:13 Changed 10 years ago by Piotrek Koszuliński

Resolution: invalid
Status: closedreopened

Yes, I agree. It's confusing why the same flags which --help shows do not work with

Last edited 10 years ago by Piotrek Koszuliński (previous) (diff)

comment:14 Changed 10 years ago by Piotrek Koszuliński

Milestone: CKEditor 4.4.2
Status: reopenedconfirmed

comment:15 Changed 10 years ago by Artur Delura

Owner: set to Artur Delura
Status: confirmedassigned

comment:16 Changed 9 years ago by Artur Delura

Resolution: fixed
Status: assignedclosed

Fixed on git:a8fe468.

Now, when running you can parametrize options like build-config. We also open-sourced CKBuilder:

Last edited 9 years ago by Piotrek Koszuliński (previous) (diff)
Note: See TracTickets for help on using tickets.
© 2003 – 2022, CKSource sp. z o.o. sp.k. All rights reserved. | Terms of use | Privacy policy