Opened 4 years ago

Closed 3 years ago

#11915 closed Bug (fixed)

Cursor jumps when typing a misspelled word with INLINE editor and SCAYT enabled

Reported by: cjarczew Owned by:
Priority: Normal Milestone: CKEditor 4.4.4
Component: General Version: 4.4.0
Keywords: Firefox Chrome Cc:

Description

Browser: FF 28, Chrome 34 (Works correctly in IE9)

OS: Win 7

Reproducible location: Demo site and nightly build

Steps to reproduce:

  1. Go to http://ckeditor.com/demo#inline
  2. Click the top right Lorem ipsum text so the toolbar shows
  3. Delete all the content
  4. Enable SCAYT
  5. Click outside the field so the toolbar goes away
  6. Click inside the field again so the toolbar appears
  7. Start typing and misspell something like so: "Hi there, how arre you doing? I am doing..."
  8. When the spell check notices the misspelled arre the cursor will jump to it and whatever you were typing will now be inserted in the middle of the sentence.

This is a big problem because my users expect to have SCAYT enabled by default and therefore I cannot use inline mode at all as this issue is reproduced consistently.

Change History (2)

comment:1 Changed 4 years ago by Piotrek Koszuliński

Status: newconfirmed

I can confirm this issue. I also found it already reported on SCAYT's bug tracker: https://github.com/WebSpellChecker/ckeditor-plugin-scayt/issues/65

comment:2 Changed 3 years ago by Anna Tomanek

Milestone: CKEditor 4.4.4
Resolution: fixed
Status: confirmedclosed

Fixed in SCAYT 4.5.3 released on July 14, 2014, as per https://github.com/WebSpellChecker/ckeditor-plugin-scayt/issues/65

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy