Opened 4 years ago

Closed 3 years ago

#11947 closed Bug (fixed)

[FF IE11] Shift+Enter in lists produces two line breaks

Reported by: Karen Ananiev Owned by: Piotrek Koszuliński
Priority: Normal Milestone: CKEditor 4.4.2
Component: UI : Enter Key Version: 4.0
Keywords: Firefox IE11 Cc:

Description

Use the code:

<ul>
	<li><strong>test</strong></li>
	<li>test</li>
</ul>

Press Shift+Enter at the end of the first line.

Expected: One line created
Actual: Two lines created

Change History (13)

comment:1 Changed 4 years ago by Piotrek Koszuliński

Status: newpending

I can't reproduce it.

  • How do you test it step by step?
  • On which version of CKEditor?
  • On which version of Firefox?
  • On which sample in which package (you can attach your build-config.js)?

comment:2 Changed 4 years ago by Karen Ananiev

Please let me know if you need more details. Thank you!

comment:3 Changed 4 years ago by Piotrek Koszuliński

Component: GeneralUI : Enter Key
Status: pendingconfirmed

Ok, I can see it. It must be the very first click. If caret is placed at the end by end button or if I click in more than one place before, I cannot reproduce it.

comment:4 Changed 4 years ago by Jakub Ś

Keywords: Firefox IE11 added
Summary: [FF] Shift+Enter in lists produces two line breaks[FF IE11] Shift+Enter in lists produces two line breaks
Version: 4.0

Problem can be reproduced from CKEditor 4.0 (works fine in beta). in IE11 and Firefox

comment:5 Changed 4 years ago by Jakub Ś

I see that brs are inserted into strong tag and below the strong tag. I believe we had such issue with br tags being inserted into strong tag but I can't find it right now.

comment:6 Changed 4 years ago by Piotrek Koszuliński

Milestone: CKEditor 4.4.2
Owner: set to Piotrek Koszuliński
Status: confirmedassigned

Hmm... that would mean that our element.getBogus method misses the <br> inserted inside <strong> by the browser. Or something similar. I have a feeling that this might be related to few other issues that we saw recently which happened at the end of line. Let's take a look at this - 4.4.2 it is.

comment:7 Changed 4 years ago by Jakub Ś

I have found issue I was talking about #8958. This isn't the same case but as I remembered it concerns brs in strong :).

comment:8 Changed 3 years ago by Piotrek Koszuliński

Status: assignedreview

Pushed branch:t/11947. The bug was caused by enter key trying to append bogus to the wrong node. It did not consider a situation when line break is inserted into an inline element.

comment:9 Changed 3 years ago by Piotr Jasiun

Status: reviewreview_failed

4 red tests in IE 11, on the t/11947 branch: http://tests.ckeditor.dev:1030/tests/plugins/enter/enterkey

Last edited 3 years ago by Piotr Jasiun (previous) (diff)

comment:10 Changed 3 years ago by Piotrek Koszuliński

Status: review_failedreview

Update benderjs-ckeditor.

comment:11 Changed 3 years ago by Piotrek Koszuliński

Oops! I forgot to mention that you must use benderjs-ckeditor/t/11947.

comment:12 Changed 3 years ago by Piotr Jasiun

Status: reviewreview_passed

Now everything looks and works fine. I rebased branch on the top on the master.

comment:13 Changed 3 years ago by Piotrek Koszuliński

Resolution: fixed
Status: review_passedclosed

Fixed on master with git:c6b36c2 in ckeditor-dev and 62c81e0 in benderjs-ckeditor.

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy