Opened 5 years ago

Closed 4 years ago

#11974 closed Bug (worksforme)

inline editing Numbered list impacts the whole document

Reported by: Pierre Owned by:
Priority: Normal Milestone:
Component: General Version: 4.3
Keywords: Webkit Blink Cc:

Description

Hi,

Steps :

1) Use inline editing

2) Input a very long first line like

Lorem ipsum dolor sit amet enim. Etiam ullamcorper. Suspendisse a pellentesque dui, non felis. Maecenas malesuada elit lectus felis, malesuada ultricies.Lorem ipsum dolor sit amet enim. Etiam ullamcorper. Suspendisse a pellentesque dui, non felis. Maecenas malesuada elit lectus felis, malesuada ultricies.Lorem ipsum dolor sit amet enim. Etiam ullamcorper. Suspendisse a pellentesque dui, non felis. Maecenas malesuada elit lectus felis, malesuada ultricies.

3) select it all

4) then click numbered list

=> there are ol and li tags inserted everywhere in the page :(

If you unselect, reselect and the click numbered list again, you can even achieve freezing the whole page.

It doesn't necessarily have to be the first line for this bug to occur but this is the simplest way I found to reproduce it.

Happens in the 4.4.0 and the nightly build at least. Happens in chrome and opera (firefox and IE seem to be OK)

Attachments (2)

2014-05-19_1623.swf (1.4 MB) - added by Jakub Ś 5 years ago.
2014-05-19_1641.swf (1.0 MB) - added by Jakub Ś 5 years ago.

Change History (7)

comment:1 Changed 5 years ago by Piotrek Koszuliński

Keywords: numbered list inline editing ol li removed
Status: newpending
Version: 4.4.0

I can't reproduce it.

Last edited 5 years ago by Piotrek Koszuliński (previous) (diff)

comment:2 Changed 5 years ago by Pierre

I'm using opera 21 and chrome 34 on Windows.

You type some words, you select those and then paste many times. Select all content using Ctral+A or mouse. Them click numbered list.

I did reproduce it on http://nightly.ckeditor.com/14-05-19-06-06/full/samples/inlinebycode.html (i deleted everything and then followed the above steps)

Have fun

comment:3 Changed 5 years ago by Pierre

It also work with bullet list

comment:4 Changed 5 years ago by Jakub Ś

Keywords: Webkit Blink added
Status: pendingconfirmed
Version: 4.3

Problem can be reproduced from CKEditor 4.3 in Blink and Webkit.

Changed 5 years ago by Jakub Ś

Attachment: 2014-05-19_1623.swf added

Changed 5 years ago by Jakub Ś

Attachment: 2014-05-19_1641.swf added

comment:5 Changed 4 years ago by Jakub Ś

Resolution: worksforme
Status: confirmedclosed

It seems this issue in no longer reproducible. It has expired on CKEditor 4.4.2 and new version of this bug has taken over. New bug version was reported here: #12484.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy