Opened 10 years ago

Closed 10 years ago

#1199 closed Bug (worksforme)

Opera: deleting of Page Break sometimes crashes Opera.

Reported by: Aleksey Onopriyenko Owned by: Hallvord R. M. Steen (Opera Software)
Priority: Must have (possibly next milestone) Milestone: Opera Compatibility
Component: General Version:
Keywords: Cc:

Description

Sometimes deleting of Page Break leads to crash.

Steps to reproduce:

  1. Load sample01.html
  2. Move cursor at the end of text.
  3. Insert Page Break (click on 'Insert Page Break' button)
  4. Press Up, End, Delete . Opera crashes.

Tested with Opera 9.5 build 9500. Opera 9.23 doesn't have this bug.

Change History (6)

comment:1 Changed 10 years ago by Hallvord R. M. Steen (Opera Software)

Owner: set to Hallvord R. M. Steen (Opera Software)
Status: newassigned

Filed as Opera bug 286921. I'm having problems creating a minimal TC but it's fairly easy to reproduce in the app itself.

comment:2 Changed 10 years ago by Frederico Caldeira Knabben

I'm not able to reproduce it anymore with Opera 9.50 build 9562. It seams it has been fixed at Opera's side.

Can you confirm it Hallvord?

comment:3 Changed 10 years ago by Frederico Caldeira Knabben

Priority: NormalHigh

comment:4 Changed 10 years ago by Hallvord R. M. Steen (Opera Software)

It is apparently fixed but the fix is not yet in builds so I think FCKEditor is doing some mind-reading to avoid the crasher :)

comment:5 Changed 10 years ago by Frederico Caldeira Knabben

I'm not able to reproduce it with Opera build 9608. I'm leaving this one to you to close it, Hallvord.

comment:6 Changed 10 years ago by Hallvord R. M. Steen (Opera Software)

Resolution: worksforme
Status: assignedclosed

Yes, no longer reproducable.

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy