Opened 4 years ago

Closed 4 years ago

#12000 closed Bug (fixed)

[Nested widgets] Widgets are not initialized inside nested editables

Reported by: Piotrek Koszuliński Owned by: Piotrek Koszuliński
Priority: Normal Milestone: CKEditor 4.4.2
Component: UI : Widgets Version: 4.3 Beta
Keywords: Cc:

Description (last modified by Piotrek Koszuliński)

Part of #10931.

  1. On editor setData.
  2. On nested editable setData.
  3. On undo/redo.
  4. On paste (insertHtml in general).

Notes:

  1. initOnAll must enter nested editables.
  2. checkWidgets must be reviewed.

Change History (9)

comment:1 Changed 4 years ago by Piotrek Koszuliński

Description: modified (diff)
Status: newconfirmed

comment:2 Changed 4 years ago by Piotrek Koszuliński

Owner: set to Piotrek Koszuliński
Status: confirmedassigned

comment:3 Changed 4 years ago by Piotrek Koszuliński

I've implemented a set of basic integration tests for initializing nested widgets on setData, nestedEditable.setData, undo/redo and pasting. All except one pass after 1LOC fix which I pushed in branch:t/12000. Unfortunately, the one is rather strange and related to incorrect selection stored with snapshot in undo manager, which totally breaks undoing.

comment:4 Changed 4 years ago by Piotrek Koszuliński

Status: assignedreview

Pushed both branches. I needed to extract #12018 because it turned out to be a separate big topic. So this ticket focuses on initialization, without garbage collecting and destroying.

comment:5 Changed 4 years ago by Piotrek Koszuliński

I also simplified a sample and added a console there.

comment:6 Changed 4 years ago by Piotrek Koszuliński

Status: reviewreview_failed

One of new test is failing on IE9 :(.

comment:7 Changed 4 years ago by Piotrek Koszuliński

Status: review_failedreview

Fortunately it was only a bug in the tests.

comment:8 Changed 4 years ago by Olek Nowodziński

Status: reviewreview_passed

Pushed a single commit to test branch. Everything seems to be fine.

comment:9 Changed 4 years ago by Piotrek Koszuliński

Milestone: CKEditor 4.4.2
Resolution: fixed
Status: review_passedclosed

Fixed on master with git:fd15d20 on dev and c0d3ae8 on tests.

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy