Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#12006 closed Bug (fixed)

[Nested widgets] Drag and drop of nested block widgets

Reported by: Olek Nowodziński Owned by: Olek Nowodziński
Priority: Normal Milestone: CKEditor 4.5.0 Beta
Component: General Version: 4.3 Beta
Keywords: Cc:

Description (last modified by Piotrek Koszuliński)

Part of #10931.

At the moment there's no way to drag and drop any block widget within nested editable because "drop lines " are not shown in nested editables at all.

Change History (11)

comment:1 Changed 4 years ago by Jakub Ś

Status: newconfirmed

comment:2 Changed 4 years ago by Piotrek Koszuliński

Description: modified (diff)
Summary: [Nested widgets] Drag and drop of nested widgets[Nested widgets] Drag and drop of nested block widgets

I made it a block widgets only ticket. Inline widgets dnd will be handled in different ticket.

comment:3 Changed 4 years ago by Piotrek Koszuliński

#12072 - the same case - inline widgets.

comment:4 Changed 4 years ago by Olek Nowodziński

Owner: set to Olek Nowodziński
Status: confirmedassigned

comment:5 Changed 4 years ago by Olek Nowodziński

Status: assignedreview

Pushed changes and tests to branch:t/12006:

  • Drag and drop of block widgets is enabled for nested editables.
  • Drag and drop considers filters (allowedContent). If the widget is disallowed in some nested editable, there's no chance it's dropped there (no drop line is displayed).
  • Prevented pathological drop into widget's own nested editable.

comment:6 Changed 4 years ago by Olek Nowodziński

Milestone: CKEditor 4.4.2

comment:7 Changed 4 years ago by Piotrek Koszuliński

Milestone: CKEditor 4.4.2CKEditor 4.5.0

This is definitely a ticket for major release, because it changes the behaviour of dnd. Prior to 4.5 nested widgets are not enabled (dnd, insertion etc). Enabling dnd in 4.4.2 would suddenly unlock the ability to nest widgets and that's not safe for a minor release.

comment:8 Changed 4 years ago by Piotrek Koszuliński

I reported followups for this ticket: #12091, #12090.

comment:9 Changed 4 years ago by Piotrek Koszuliński

Status: reviewreview_passed

R+. Doesn't work on IE8 but we don't plan to have nested widgets support in IE8 yet, so it's ok.

comment:10 Changed 4 years ago by Piotrek Koszuliński

Remember to rearrange commits in the branch so tests go after dev.

comment:11 Changed 4 years ago by Olek Nowodziński

Resolution: fixed
Status: review_passedclosed

git:541f71b landed in major

Last edited 4 years ago by Olek Nowodziński (previous) (diff)
Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy