Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#12055 closed Bug (invalid)

HTML5 support

Reported by: Matti Järvinen Owned by:
Priority: Normal Milestone:
Component: Core : DTD Version:
Keywords: Cc:

Description

With HTML source:

<article>
    <h1>Hi</h1>
    <p>Lipsum</p>
</article>

Current nightly produces:

<h1>Hi</h1>

<p>Lipsum</p>

Steps to reproduce:

  1. Change to source view
  2. Paste above HTML snippet
  3. Change back to WYSIWYG
  4. No more article tags

In #4556 [6988] initial HTML5 support was added. Did this work at all in any point or was it broken with ACF? core/dtd.js lists most of HTML5 elements including article.

Change History (2)

comment:1 Changed 5 years ago by Jakub Ś

Resolution: invalid
Status: newclosed

When editor starts, plugins report allowed content to it. Tag article is not allowed because there is no plugin for it. What you can do is using extraAllowedContent : 'article' and then it will work. You can also disable ACF but we don't recommend that unless you want to allow your users inserting every tag into editor.

Last edited 5 years ago by Jakub Ś (previous) (diff)

comment:2 Changed 5 years ago by Matti Järvinen

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy