Opened 4 years ago

Closed 3 years ago

#12095 closed Bug (fixed)

Moving inline widget lose applied style (e.g. bold)

Reported by: Daniele Arancia Owned by: Piotr Jasiun
Priority: Must have (possibly next milestone) Milestone: CKEditor 4.5.0 Beta
Component: General Version: 4.3 Beta
Keywords: Cc:

Description (last modified by Piotrek Koszuliński)

Part of: #11437

  1. open placeholder plugin
  2. select a placeholder
  3. apply "bold" style to selected placeholder (or another style change)
  4. drag the placeholder to another position

Result: moved placeholder lose applied style

Change History (13)

comment:1 Changed 4 years ago by Jakub Ś

Keywords: placeholder selection style removed
Version: 4.4.14.3.4

I was able to reproduce this issue from CKEditor 4.3.4 in every browser. Before this version placeholder plugin had bug not allowing it to be used with other plugins.

I don't think however that this problem is in fact a bug. Bold style is applied around the placeholder widget main wrapping tag. When you move placeholder you can't move parent tags around it. Widget doesn't care about its parent tags when dragged.

IMO when one wants bold place holder he should create such place holder plugin or modify existing plugin.

comment:2 Changed 4 years ago by Jakub Ś

Resolution: invalid
Status: newclosed

comment:3 Changed 4 years ago by Daniele Arancia

Ok, Thanks, I understand, but there is an event that I can overwrite in order to be able to modify the placeholder widget's content to swap strong tag on click on bold button? I need to be able to drag and drop placeholder widget without losing applied style. Many thanks in advance! Daniele

comment:4 Changed 4 years ago by Piotrek Koszuliński

Resolution: invalid
Status: closedreopened
Version: 4.3.44.3 Beta

From strictly technical POV it makes sense to move placeholder only when dragging placeholder. But from UX POV it definitely makes sense to move entire styling. The same as copy&paste works.

comment:5 Changed 4 years ago by Piotrek Koszuliński

I'm setting temporarily milestone to 4.5, because we're working on drag and drop and will touch this part of code. Let's see if it will be fixed automatically.

comment:6 Changed 4 years ago by Piotrek Koszuliński

Description: modified (diff)
Milestone: CKEditor 4.5.0
Summary: moving placeholder lose applied styleMoving inline widget lose applied style (e.g. bold)

comment:7 Changed 4 years ago by Jakub Ś

Status: reopenedconfirmed

Since @Reinmar says it may be doable, I'm confirming this issue.

NOTE: Just please remember to isolate this issue in order to avoid too greedy dragging in other situations.

comment:8 Changed 4 years ago by Daniele Arancia

We had no news since the bug opening. Do you plan to resolve this bug in any of the next releases? Thank you.

comment:9 Changed 4 years ago by Piotrek Koszuliński

This will be fixed in 4.5.0. We've been working hard for last couple of months on many APIs required to fix this issue. See http://dev.ckeditor.com/query?group=status&milestone=CKEditor+4.5.0 for list of changes so far - many of there were required so we'll be able to close this ticket.

comment:10 Changed 3 years ago by Piotrek Koszuliński

Priority: NormalHigh

comment:11 Changed 3 years ago by Piotr Jasiun

Owner: set to Piotr Jasiun
Status: confirmedassigned

comment:12 Changed 3 years ago by Piotr Jasiun

Done, as a part of #13042. Thanks for your patience ;)

comment:13 Changed 3 years ago by Piotr Jasiun

Resolution: fixed
Status: assignedclosed
Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy