Opened 10 years ago

Closed 10 years ago

#121 closed Bug (fixed)

Editor size is wrong in full-window mode inside frameset

Reported by: madpolice Owned by: Martin Kou
Priority: Normal Milestone: FCKeditor 2.5 Beta
Component: UI : Floating Panel Version: FCKeditor 2.4
Keywords: Confirmed IE Cc:

Description

<frameset cols="175,*">

<frame name="left" src="left.asp" target="main" scrolling="auto"> <frame name="main" src="main.asp">

</frameset>

main.asp contains a fckeditor.

bug: the editor's size (width & height) is wrong on full-window mode.

editor uses browser's available width and height, but this is not page's available size when page in a frame.

Attachments (2)

frameset.html (413 bytes) - added by Frederico Caldeira Knabben 10 years ago.
Test frameset structure
frames2.html (804 bytes) - added by websitemaker@… 10 years ago.
frameset where IE7 window max induces failure

Download all attachments as: .zip

Change History (12)

Changed 10 years ago by Frederico Caldeira Knabben

Attachment: frameset.html added

Test frameset structure

comment:1 Changed 10 years ago by Frederico Caldeira Knabben

Keywords: WorksForMe added
Summary: editor's size is wrong in full-window mode when page with a frameEditor size is wrong in full-window mode inside frameset

It works well for me with both IE6 and FF2 using the attached frameset page.

comment:2 Changed 10 years ago by Frederico Caldeira Knabben

Keywords: Pending added

Do you have more info about the problem? Does the attachment works for you?

comment:3 Changed 10 years ago by websitemaker@…

I can verify this is a genuine bug. I just came here to report it and found this pre-existing report.

The problem occurs in IE7. I have tested in FireFox 2.0x and functionality is fine there.

If you have a frame structure, and one of the windows has FCKEditor in it, and you use the window maximization button the window will not enlarge properly; instead enlarging itself to a size wider than the actual current window. The toolbar appears normal however that may only be because I am using only a few buttons.

The problem is actually quite a bit worse than what is detailed here and I'll detail the separate behavior in a separate ticket, but I wanted to confirm this existing report.

Changed 10 years ago by websitemaker@…

Attachment: frames2.html added

frameset where IE7 window max induces failure

comment:4 Changed 10 years ago by websitemaker@…

I have a replicable example. Open up the attached html page and place it in the FCKEditor root. Run it. Note that it calls the ColdFusion connector (and note the original report was for ASP). Click FitWindow.

These elements will result in failure:

  1. Paste in text repeatedly until the window scrolls. Note how after the window fills the editor toolbar scrolls up, which shouldn't happen. Try to scroll back up. The toolbar is now gone forever.
  1. Click 'View Source'. There's no way to get out of source mode.

So long as you do not hit FitWindow you are fine. Once you do that and you scroll while in the enlarged window your editing session is doomed.

comment:5 Changed 10 years ago by Frederico Caldeira Knabben

Keywords: Confirmed IE added; WorksForMe Pending removed
Version: FCKeditor 2.4

Ok... confirmed with IE6 and IE7. Ok with FF2.

It happens with both TCs as long as you as using a server side integration, like ColdFusion or PHP. It will work well if you instead load the html samples in the frame.

The editor resizes more than the space available in the frame.

comment:6 Changed 10 years ago by Frederico Caldeira Knabben

Correcting myself... it has nothing to do with the server side integration. Its a problem with DOCTYPE. It will break on quirks mode and works well with strict.

To test it, just place the following DOCTYPE (HTML 4) in sample01.html:

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN">

It works well instead with:

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">

So, it is a quirks thing.

comment:7 Changed 10 years ago by websitemaker@…

Confirmed. This fixes all issues. Thanks!

comment:8 Changed 10 years ago by Frederico Caldeira Knabben

Component: GeneralUI : Floating Panel
Milestone: FCKeditor 2.5

comment:9 Changed 10 years ago by Martin Kou

Owner: set to Martin Kou
Status: newassigned

comment:10 Changed 10 years ago by Martin Kou

Resolution: fixed
Status: assignedclosed

Fixed with [722]. Now "Maximize editor size" works correctly even if the container document is in quirks mode.

Click here for more info about our SVN system.

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy