Opened 5 years ago

Closed 5 years ago

#12211 closed Bug (invalid)

Bug in API on insertElement and insert HTML

Reported by: Packwin Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: Cc:

Description

I am developing a CKEDITOR plugin which captures image pastes in the editor and uploads them to a server. The problem is occuring in an editor.document.on("paste", function...) callback when I try to add a loading gif placeholder using editor.insertElement or editor.insertHtml, and it only happens when nothing has been entered into the editor already. On either of these function calls, I get a TypeError with the message "Cannot read property 'checkReadOnly' of undefined". This happens in Chrome only (I am running windows 8.1), and does not happen in Firefox or IE 11 (Earlier versions of IE don't trigger paste events so not sure about those). If this bug wasn't weird enough already, there is one last weirdness about it. Later in the paste handler, the editor.insertElement function works for inserting the image that was pasted. Sorry if this is unclear but that's the best I can give you.

Change History (1)

comment:1 Changed 5 years ago by Jakub Ś

Resolution: invalid
Status: newclosed
Version: 4.4.2

We are in fact working on data input handling which should be ready for CKEditor 4.5.

A lot number of issues including your one should be handled with that change. Please see: #11437.


As for your ticket, I see that you are creating custom plugin which you have problem with. This makes this ticket invalid for me because it is custom plugin specific and not CKEditor genral error.

If you believe there is some error in CKEditor, please provide reduced test-case file that shows this error. I'm talking about some HTML page (with JS files if needed) that can be put in samples folder and will show this issue.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy