Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#12237 closed Bug (invalid)

AVT: Drag & Drop functionality of widgets not keyboard Accessible

Reported by: Satya Minnekanti Owned by:
Priority: Normal Milestone:
Component: Accessibility Version: 4.3
Keywords: IBM Cc: Irina

Description

To reproduce the defect:

Open Sample widgets page http://ckeditor.com/demo#widgets

Issue: All widgets( Simple Box, Code Snippet, Enhanced Image, Mathematical Formulas) can be dragged and dropped using mouse but not with keyboard. This is a Violation of Accessibility Checkpoint 2.1a Keyboard

Change History (3)

comment:1 Changed 5 years ago by Frederico Caldeira Knabben

Resolution: invalid
Status: newclosed

This is covered by "cut and paste".

comment:2 Changed 5 years ago by Satya Minnekanti

Hi Fred,Please re-open this ticket. There is no way to select whole widget with just one Keyboard shortcut just like you do with mouse, and also JAWS or blind users does not know whether they have selected whole widget or not, if you look at an image user can select whole image with just one arrow key(left/right) and JAWS will read Graphic selected, where as it won't be possible in this case. This needs to be fixed.

comment:3 in reply to:  2 Changed 5 years ago by Frederico Caldeira Knabben

Replying to satya:

Hi Fred,Please re-open this ticket. There is no way to select whole widget with just one Keyboard shortcut just like you do with mouse, and also JAWS or blind users does not know whether they have selected whole widget or not, if you look at an image user can select whole image with just one arrow key(left/right) and JAWS will read Graphic selected, where as it won't be possible in this case. This needs to be fixed.

Ok, but this issue seems to be #12235 instead, right? In that case, this should be discussed there.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy