Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#12252 closed Bug (invalid)

Disabled cut/copy in Firefox and Chrome

Reported by: FrankC Owned by:
Priority: Normal Milestone:
Component: General Version: 4.4.2
Keywords: Firefox, Chrome, cut, copy, paste Cc:

Description

I've been participating in at least two dozen forums of web developers, and have thus used probably all post editors there are. In all, the cut, copy and paste functions also work when Firefox or Chrome are used. Both via the buttons and via the context menu (right-click menu) options. And in this very form that I'm using right now said matters function as well.

Not so in CKEditor (this form editor is not CKEditor). Why still not? Regarding Chrome, this seems to have been reported as bug under ticket nr. 8463. Which was closed because it supposedly was fixed. But that is not the case. And clearly, it is a bug. Because why else do all the other form editors function flawlessly in FF and Chrome?

Change History (7)

comment:1 Changed 5 years ago by FrankC

I've been participating in at least two dozen forums of web developers, and have thus used probably all post editors there are. In all, the cut, copy and paste functions also work when Firefox or Chrome are used. Both via the buttons and via the context menu (right-click menu) options. And in this very form that I'm using right now said matters function as well.

Not so in CKEditor (this form editor is not CKEditor). Why still not? Regarding Chrome, this seems to have been reported as bug under ticket nr. 8463. Which was closed because it supposedly was fixed. But that is not the case. And clearly, it is a CKEditor design flaw (which is not a tag option, so I'm entering it as a bug). Because why else do all the other form editors function flawlessly in FF and Chrome?

comment:2 Changed 5 years ago by Piotrek Koszuliński

Resolution: invalid
Status: newclosed

Discussion on SO: http://stackoverflow.com/questions/24970405/disabled-cut-copy-paste-functions-in-ckeditor-with-firefox-and-chrome-workar

My answer there clarifies that JS based solution isn't yet possible. So for now it's a "can't fix" ticket. When situation will change we'll create new one.

comment:3 Changed 5 years ago by FrankC

Thanks for the quick reply, which is truly appreciated.

But "can't fix" and "JS-based solution isn't yet possible" I don't understand. Just use the CKEditor post form (v.3, I believe) on Sitepoint (http://www.sitepoint.com/forums/forumdisplay.php?15-JavaScript), after having registered. And see for yourself that the said functions are working perfectly well in FF and Chrome, too.

And from what I can see, they did that by means of (deleting a) Javascript. Not with Java or Flash, because the first is disabled in my FF, and the second doesn't work on iPads.

Last edited 5 years ago by FrankC (previous) (diff)

comment:4 Changed 5 years ago by Piotrek Koszuliński

I waited an hour for Sitepoint's email to come and nothing, so I can't use my account.

comment:5 Changed 5 years ago by FrankC

That may be because they're preparing the migration to a new forum platform, away from vBulletin. Send me a mail on f dot conijn at gmail dot com, and I'll send you either my account data or those of one I'm gonna try to create for you.

comment:6 Changed 5 years ago by Piotrek Koszuliński

Well, let's just wait. I contacted Sitepoint's admins and yes - problems are caused by their new architecture. As soon as I have the account I'll check it.

comment:7 Changed 5 years ago by FrankC

I just created an account for you (Reinmar CKE), confirmed and all. If you would like to use that, just mail me so I can send you the password. It would be wise to not wait too long, because pretty soon the migration will take place, and the new platform might not use CKE anymore.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy