Opened 4 years ago

Closed 2 years ago

#12342 closed Bug (wontfix)

CKEditor in IE 11 Enterprise Mode with Compatibility Mode not working

Reported by: Tim Reg Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: Cc:

Description (last modified by Piotrek Koszuliński)

Trying the samples in IE 11 with Enterprise mode enabled. They do not display correctly. See attachment.

Tried it with 4.3.3, 4.4.3 and 4.4.4

Thanks.


Workaround: see comment:3.

Attachments (1)

replacebyclass.gif (105.9 KB) - added by Tim Reg 4 years ago.
Replace by Class sample screenshot

Download all attachments as: .zip

Change History (9)

Changed 4 years ago by Tim Reg

Attachment: replacebyclass.gif added

Replace by Class sample screenshot

comment:1 Changed 4 years ago by Tim Reg

I've done some debugging. The CKEDITOR.env.isCompatible was returning false because of the user agent string: "mozilla/4.0 (compatible; msie 7.0; windows nt 6.1; slcc2; .net clr 2.0.50727; .net clr 3.5.30729; .net clr 3.0.30729; media center pc 6.0; /net clr 1.1.4322; .net4.0c; .net4.0e)" is missing any "trident" reference which the env.js is using to identify IE.

However, I also discovered this only happens when both Enterprise mode is on and the compatibility view settings include the current web address.

For Enterprise Mode only without compatibility, the user agent is: "mozilla/4.0 (compatible; msie 8.0; windows nt 6.1; trident/4.0; slcc2; .net clr 2.0.50727; .net clr 3.5.30729; .net clr 3.0.30729; media center pc 6.0; /net clr 1.1.4322; .net4.0c; .net4.0e)" and this works.

comment:2 Changed 4 years ago by Piotrek Koszuliński

After http://msdn.microsoft.com/en-us/library/dn640687.aspx:

Enterprise Mode, a compatibility mode (...)

Indeed, great "compatibility mode" if they created a new UA string for it. Microsoft doesn't stop making things worse. Now IE11 can work in 4 modes - std, nearly std, IE5 quirks and enterprise and maybe even compat mode.

We'll investigate this as soon as we'll find out how to turn on the Enterprise Mode.

comment:3 Changed 4 years ago by Piotrek Koszuliński

Description: modified (diff)
Version: 4.4.4

BTW. a simple workaround is explained in this (unfinished) document: https://github.com/ckeditor/ckeditor-docs/issues/20

comment:4 Changed 4 years ago by Piotrek Koszuliński

And a useful video about how to enable EM: https://www.youtube.com/watch?v=16oyRYLs2GQ

comment:5 in reply to:  1 Changed 4 years ago by Piotrek Koszuliński

Replying to timreg:

I've done some debugging. The CKEDITOR.env.isCompatible was returning false because of the user agent string: "mozilla/4.0 (compatible; msie 7.0; windows nt 6.1; slcc2; .net clr 2.0.50727; .net clr 3.5.30729; .net clr 3.0.30729; media center pc 6.0; /net clr 1.1.4322; .net4.0c; .net4.0e)" is missing any "trident" reference which the env.js is using to identify IE.

However, I also discovered this only happens when both Enterprise mode is on and the compatibility view settings include the current web address.

For Enterprise Mode only without compatibility, the user agent is: "mozilla/4.0 (compatible; msie 8.0; windows nt 6.1; trident/4.0; slcc2; .net clr 2.0.50727; .net clr 3.5.30729; .net clr 3.0.30729; media center pc 6.0; /net clr 1.1.4322; .net4.0c; .net4.0e)" and this works.

That's odd actually, because according to http://msdn.microsoft.com/en-us/library/ie/hh869301(v=vs.85).aspx in both cases there should be a 'Trident' keyword in the UA. I'll have to check this on my machine.

comment:6 Changed 4 years ago by Piotrek Koszuliński

Status: newpending
Summary: CKEditor in IE 11 Enterprise Mode not workingCKEditor in IE 11 Enterprise Mode with Compatibility Mode not working

I confirmed that when Enterprise and Compatibility Modes are on, the UA string is set to some odd value which does not contain "Trident" keyword. In any other constellation of modes that keyword is always present.

I'm not sure whether we're going to change IE detection to fix this issue, because it's a very special case in which system administrator should know what (s)he's doing. User cannot enable EM and CM by mistake, so it has to be a conscious decision of the admin.

In such case the admin can edit this line to fix IE detection and that's it.

Leaving this ticket for a discussion.

comment:7 Changed 4 years ago by Tim Reg

I tend to agree that Enterprise and Compatibility modes should not be enabled at the same time. I didn't realize it was going to lead to this problem but now that I know I think we can avoid it. Thanks.

comment:8 Changed 2 years ago by Jakub Ś

Resolution: wontfix
Status: pendingclosed
Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy