Opened 4 years ago

Closed 3 years ago

#12355 closed Bug (fixed)

Demo page doesn't load in Chrome on Android

Reported by: Joel Davis Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: Android Chrome Mobile Cc:

Description

I was testing CKEditor on different devices and found the demo page doesn't load in Chrome on any of the Android devices I tested.

Chrome version 36.0.1985.135, Sony xperia.

Also tested Samsung Galaxy and Samsung Note, same issue.

Demo page is currently using 4.4.4 (Standard) (revision 1ba5105)

Note from FAQ: CKEditor supports mobile versions of Safari (default browser on iPhone and iPad) and Chrome (available for Android and preinstalled on many Android devices) with minor issues related to platform limitations.

Change History (9)

comment:1 Changed 4 years ago by Jakub Ś

Keywords: demo mobile android removed
Resolution: duplicate
Status: newclosed
Version: 4.4.4

DUP of #10063.

As explained in that ticket, CKEditor is disabled on Android on purpose. You can turn it on and check how it works. You need to download source or git version of CKEditor and modify - ckeditor/core/env.js.

comment:2 Changed 4 years ago by Piotrek Koszuliński

Resolution: duplicate
Status: closedreopened

@j.swiderski - this is an outdated ticket from 4.0.1. List of supported browsers has changed since then.

This is a known problem with browser version detection. When we were testing Android support we used devices on which Chrome is detected as a desktop browser and based on that we updated our FAQ and documentation. Then we found out that on some other devices Chrome is not correctly detected and therefore CKEditor is disabled.

We haven't yet got time to test more devices, so we can't change browser detection in the core, but we are preparing a documentation on how to enable CKEditor on unsupported environments. You can see a draft of this guide here - https://github.com/ckeditor/ckeditor-docs/tree/master/guides/dev/deep_dive/unsupported_environments

We'll be grateful for any information about how CKEditor works in these environments. A feedback will allow us to update browser detection in the core.

comment:3 Changed 4 years ago by Piotrek Koszuliński

Keywords: Android Chrome Mobile added
Status: reopenedconfirmed

comment:4 Changed 4 years ago by Joel Davis

Thanks for pointing me in the direction of that guide.

I have managed to get it working in our dev environment.

There are few little bugs on mobile, but will still work well for our application.

Happy to do some further testing across many devices and let you know what issues we have.

comment:5 Changed 4 years ago by sirtet

4.4.4 works fine for me on android 4.4.4 chrome & opera, if they are in desktop mode.

I would suggest a message incompatible browser detected, editor disabled, to ease the enduser's bughunt.

Even better, add an option to try loading anyways. You could leave a warning in the UI unsupported- mode. Or the helpful tip try to switch to desktop view.

PS: If you were serious to exclude android chrome, you should exclude mobile- and desktop mode, as I guess the only difference is the user agent string, right?

comment:6 Changed 4 years ago by Piotrek Koszuliński

I think that we could throw an error if unsupported environment is detected. We can consider this. Leaving a warning in the UI and trying to load is not a possible solution, because editor will load, but it may not work and then user will not be able to do anything.

As for Android Chrome (mobile mode) - we did not intentionally exclude it. We never did officially support it hence editor is disabled on it. But if it's really the same as Android Chrome in desktop mode (on which editor works), we will enable editor on it. We just need enough information about how editor works in this mode and on which devices precisely, so we are able to make a decision. That's why we created this guide - Enabling editor in unsupported environments.

comment:7 Changed 4 years ago by sirtet

Yes, I guess something SHOULD be done. I am quite sure Chrome in mobile mode is a default since quite some time. Check your demo's page visits from android mobile. All those users will go WTF? And wander away...

was never officially supported

The FAQ should be clarified then.

Leaving a warning in the UI and trying to load is not a possible solution, because editor will load, but it may not work and then user will not be able to do anything.

Adding a disable editor link should be trivial, no?

I thought you guys could answer if chrome's (or all mobile browsers) change only their ua-string, or also change the rendering. if not, I'll search for answers.

comment:8 Changed 4 years ago by Piotrek Koszuliński

Adding a disable editor link should be trivial, no?

You miss the point. CKEditor is only a component and should not try to handle too much by itself. It's developers, who are integrating CKEditor with their systems, job to handle such situations. CKEditor cannot take control over its surrounding.

I thought you guys could answer if chrome's (or all mobile browsers) change only their ua-string, or also change the rendering. if not, I'll search for answers.

According to our research CKEditor worked out of the box on Android devices we tested. Based on that we updated the FAQ pretty recently. Soon after we learned that we didn't test enough devices, because on some (maybe even most) mobile mode is default - not desktop mode. We lack resources to make thorough tests that's why we asked for feedback and we plan to update CKEditor or FAQ/docs soon.

comment:9 Changed 3 years ago by Piotrek Koszuliński

Resolution: fixed
Status: confirmedclosed

Since CKEditor 4.5 we disabled the compatibility check. Now, CKEditor will try to load on every browser except some very old ones that we know we do not support. We also updated the documentation. See http://docs.ckeditor.com/#!/guide/dev_browsers-section-a-word-about-mobile-environments

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy