Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#124 closed Bug (duplicate)

BRs being lost (EnterMode-related?)

Reported by: MarcusL Owned by:
Priority: Normal Milestone: FCKeditor 2.4.1
Component: UI : Enter Key Version: FCKeditor 2.4
Keywords: Cc:

Description

Repro instructions:

  1. go to http://www.fckeditor.net/demo
  2. ctrl-a (select all), delete
  3. ctrl-b (bold) type "bold"
  4. shift-enter (br)
  5. ctrl-b (unbold) ctrl-i (italic) type "italic"

expected html (FCK 2.3 behavior):

<strong>bold<br/>
</strong><em>italic</em>

output html (FCK 2.4):

<p><strong>bold</strong>
<em>italic></em></p>

For some reason the <br/> is getting lost on posting (or switching from design to source view).

This behavior is exhibited in Fx 2.0.0.1 and IE7

Comments from SourceForge Bug Report:


Date: 2007-02-16 02:36

Same problem in IE6... please resolve this ASAP since it is a blocking bug in our applications.

Attachments (1)

FCK remove br.avi (132.1 KB) - added by anonymous 12 years ago.
FCK remove <br /> after any closing tags #168 doesn't work

Download all attachments as: .zip

Change History (4)

comment:1 Changed 12 years ago by Frederico Caldeira Knabben

Keywords: EnterMode BR removed
Milestone: FCKeditor 2.4
Priority: HighNormal

It is much probably a DUP of #122, with the exception that the issue is reported with Firefox too.

In my tests, I have no problems with Firefox. Can you please confirm it is not a IE only issue?

comment:2 Changed 12 years ago by Frederico Caldeira Knabben

Resolution: duplicate
Status: newclosed

Confirmed as a DUP of #90.

comment:3 Changed 12 years ago by Frederico Caldeira Knabben

Milestone: FCKeditor 2.4FCKeditor 2.4.1

Changed 12 years ago by anonymous

Attachment: FCK remove br.avi added

FCK remove <br /> after any closing tags #168 doesn't work

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy