Opened 4 years ago

Closed 4 years ago

#12402 closed Bug (fixed)

Regression in Chrome 37 causes document title to stop updating

Reported by: Piotrek Koszuliński Owned by: Piotrek Koszuliński
Priority: Normal Milestone: CKEditor 4.4.5
Component: General Version:
Keywords: Chrome Cc:

Change History (6)

comment:1 Changed 4 years ago by Piotr Jasiun

Status: newconfirmed

comment:2 Changed 4 years ago by Piotrek Koszuliński

Owner: set to Piotrek Koszuliński
Status: confirmedassigned

comment:3 Changed 4 years ago by Piotrek Koszuliński

Description: modified (diff)
Summary: Series of red tests on Chrome 37Regression in Chrome 37 causes document title to stop updating

comment:4 Changed 4 years ago by Piotrek Koszuliński

It seems that regression in feature that worked for years is not important for Chromium team (https://code.google.com/p/chromium/issues/detail?id=411111#c5), so we need to workaround this on our side.

comment:5 Changed 4 years ago by Piotrek Koszuliński

Status: assignedreview

Pushed branch:t/12402.

I couldn't run full tests suite on IE8 and IE11, because they've been pretty crashy today. But the specific tests that were failing are now passing on every browser I checked (IE8, 11, Chrome, Firefox).

Additional TC:

  1. Open doc props sample.
  2. CKEDITOR.instances.editor1.setData('<html><head><title>foo</title></head><body></body></html>')
  3. Open doc props dialog - see that the title is still empty.

comment:6 Changed 4 years ago by Piotrek Koszuliński

Resolution: fixed
Status: reviewclosed

Fixed on master with git:5850e0e.

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy