Opened 4 years ago

Closed 20 months ago

#12465 closed Bug (fixed)

Can't update checkbox/radio button state with dialog when it is opened with double-click

Reported by: Jakub Ś Owned by: Tomasz Jakut
Priority: Normal Milestone:
Component: General Version: 3.3
Keywords: Blink Webkit Support Cc:

Description (last modified by Jakub Ś)

In Blink and Webkit it is impossible to change state of checkboxes/radiobuttons with properties dialog when this dialog is opened with double-click.

To reproduce:

  1. Open checkbox/radio button properties dialog.
  2. Enter all the values and press OK.
  3. Double-click on checkbox/radio button to open the checkbox/radio button properties dialog again.
  4. Click on checkbox in ckeckbox/radio button properties dialog to make it unselected and press OK.

Result: the state of checkbox/radio button is not changed (if it was checked, it is still checked).

Problem can be reproduced from CKEditor 3.3 (when opening properties dialog with double-click was made possible) in Blink and Webkit browsers.

NOTE: When you right-click on checkbox/radio button to open dialog and change its state then it works.

Change History (8)

comment:1 Changed 4 years ago by Jakub Ś

Status: newconfirmed

comment:2 Changed 4 years ago by Jakub Ś

Description: modified (diff)
Summary: Can't update checkbox state with Dialog.Can't update checkbox/radio button state with dialog when it is opened with double-click
Version: 3.03.3

comment:3 Changed 4 years ago by Jakub Ś

#13072 was marked as duplicate.

comment:4 Changed 3 years ago by Tomasz Jakut

Owner: set to Tomasz Jakut
Status: confirmedassigned

comment:5 Changed 3 years ago by Tomasz Jakut

Status: assignedreview

It seems that the bug is caused only by the double-click made by user - doing it programmatically doesn't raise an error. The fix was simple: checked property, not only attribute, should be changed. Pushed branch:t/12465.

comment:6 Changed 21 months ago by kkrzton

Status: reviewreview_failed

If the fix is only for Blink/Webkit, probably CKEDITOR.env.webkit could be used so it is only applied on those browsers? There is already bender.ignore() in manual test, so the ###ONLY IN BLINK/WEBKIT### information is not necessary IMHO.

Apart from these tiny details above, everything looks good.

comment:7 Changed 21 months ago by Tomasz Jakut

Status: review_failedreview

Pushed fixes for tests and checking for WebKit to branch:t/12465.

comment:8 Changed 20 months ago by Tade0

Resolution: fixed
Status: reviewclosed

Nothing broke due to this change, LGTM.

Fixed with git:b6612e607f32a3b6b2c94975fd7ec05da6d9be0e.

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy