Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#12471 closed Bug (invalid)

Not able to put <li> tag without <ul> Or <ol>

Reported by: Lal Saheb Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: Cc:

Description

We are not able to put any <li> tag without <ul> Or <ol> tag. Please help me out for this as this is most important for our templates. this is urgent. I have been googling from last twenty days but still not got any solutions for this. Kindly help me out for this.

Change History (3)

comment:1 Changed 5 years ago by Piotrek Koszuliński

Resolution: invalid
Status: newclosed
Version: 4.0.3

As far as I understand you want the editor to produce <li> without any <ul/ol> tags. That's impossible without tuning editor's getData() method, because CKEditor produces only valid HTML.

comment:2 in reply to:  1 Changed 5 years ago by Lal Saheb

Replying to Reinmar:

As far as I understand you want the editor to produce <li> without any <ul/ol> tags. That's impossible without tuning editor's getData() method, because CKEditor produces only valid HTML.

But the getData() method is used only to get the data from text-area which do not format the html. The htmlwriter plugin seems to responsible for the formatting. Please note that the <li> tag is automatically wrapped with <ul/ol> tag while clicking on the source tab in editor. So i just want to skip this features of editor. Please help me out for the same.

comment:3 Changed 5 years ago by Piotrek Koszuliński

This is a bug tracker and the behaviour you are referring to is not a bug but the expected behaviour.

For more help check:

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy