Opened 5 years ago

Closed 5 years ago

#12476 closed Bug (invalid)

IE8 crashes when calling insertHTML on an unordered list

Reported by: ckeditorTest Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: Cc:

Description

  1. HTML is as follows:
<ul>
<li>test 1</li>
<li>test 2</li>
</ul>
  1. Select 'test 2'
  2. Execute following js:
var CKEDITOR = parent.window.opener.CKEDITOR;
var editor1 = CKEDITOR.instances.editor1;
editor1.insertHtml('<a href="/test.doc">test 2</a>');
  1. IE 8 crashes running on Windows 7. Works ok for FF & Chrome.

works if the HTML is test 1<br /> test 2<br />

Attachments (1)

ckEditor_Inc12476.zip (2.5 KB) - added by ckeditorTest 5 years ago.
sample html

Download all attachments as: .zip

Change History (10)

comment:1 Changed 5 years ago by Jakub Ś

Keywords: ie8 crash insertHTML unordered list item removed
Status: newpending
Version: 4.4.4

I'm sorry but this code suggests that you are using popup window.

Could you send reduced and sample HTML page with this code? I'm talking about working page that can be put into CKEditor samples folder and will show this error.

NOTE: Using IE8 on Windows 7 is rather rare case especially that default IE for Windows 7 is IE9 and current one after updates is IE11.

comment:2 Changed 5 years ago by ckeditorTest

One interesting thing to note is that I do not get an IE crash when I have the browser set to use Compatibility View for my domain. I still get IE crashes when I have the meta tag set to force the page to be rendered in IE7 compatibility. ie. <meta http-equiv="X-UA-Compatible" content="IE=EmulateIE7" />. I also added the custom HTTP response header in our web server (IIS6) set X-UA-Compatible to IE=EmulateIE7. IE still crashes.

I'm running IE 8.0.7601.17514. I am able to reproduce with other users with the same configuration as me.

comment:3 Changed 5 years ago by Jakub Ś

Could you send us the sample (and working) file(s) we have asked for in comment:1?

comment:4 Changed 5 years ago by ckeditorTest

Please close this issue. I figured out a workaround. The css that was being applied through contentsCss had some extra styles. Once I removed them it worked ok. Strange why it would work in IE compatibility view and for the other browsers.

comment:5 Changed 5 years ago by Jakub Ś

Perhaps there is some glitch between contenteditable element, certain styles and innerHTML. Another possibility is that there is some bug in editor that is causing such behaviour in IE8.

It would be really nice if you could send us reduced HTML file that shows this problem in code. That way we could check it. This shouldn't be a problem especially now when you know what is the problem.

Are you sure you want to close this ticket?

comment:6 Changed 5 years ago by ckeditorTest

Looks like this is still an issue. I removed the call to contentsCss and still get the crash. I've uploaded ckEditor_Inc12476.zip that included the files to reproduce.

Steps to reproduce: 1) In IE8(make sure compabibility view is NOT enabled) open defaultTest.asp 2) Highlight test1 (without test at the end) and click File Manager icon to open the custom plugin 3) Click Insert button Should get the crash after a couple of tries.

comment:7 Changed 5 years ago by Piotrek Koszuliński

Could you report a simplified sample which does not require ASP? We can't check it. Basicly - a report should include an HTML page plus minimum number of external assets (preferably 0).

comment:8 Changed 5 years ago by ckeditorTest

I changed the .asp to .html and removed the plugin. This is the minimum number of assets that I can send you to reproduce the issue. To reproduce: 1) Open defaultTest.html 2) Highlight 'test1' (it wil work if you hightlight the complete text within the <li>) 3) Click 'Open New Window' button 4) Click 'Insert' button in popup window

Changed 5 years ago by ckeditorTest

Attachment: ckEditor_Inc12476.zip added

sample html

comment:9 Changed 5 years ago by Jakub Ś

Resolution: invalid
Status: pendingclosed

I have been checking this issue for quite a while now but I was unable to reproduce this problem.

Please note that I have been checking this issue in IE8 Win XP and IE11 Win 7. I haven't checked IE8 on IE7 because this is not the browser for this System. Default is IE9 which gets auto-updated to IE10 and IE11.


I'm not sure what gets wrong in your application but you might want to change the method of applying link to editor. You could check code for link dialog (plugins/link/dialogs/link.js) for that.

  1. First you get selection and create range
  2. Next you apply style to selection (Please look for below code):
    		// Apply style.
    		var style = new CKEDITOR.style( {
    			element: 'a',
    			attributes: attributes.set
    		} );
    
    		style.type = CKEDITOR.STYLE_INLINE; // need to override... dunno why.
    		style.applyToRange( range, editor );
    		range.select();
    
  3. And finally you select range.
  4. To get editor source code please see: http://docs.ckeditor.com/#!/guide/dev_source

I don't see it as editor issue. I'm closing it as invalid.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy