Opened 5 years ago

Closed 4 years ago

#12492 closed Bug (duplicate)

CKE include style font-family with lowercase

Reported by: Stan Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: Cc:

Description

Hi, I found on google that this problem was discused many times - few years and to this time it`s not resolved. Crazy! When I use Google Fonts, then is impossible use font-family names to google API. Google API need strict case sensitive font names. Content with styles font-family can not be lowercase. Please improve it as soon as possible. It is too complicated do it by workaround out of CKE!

Change History (5)

comment:1 Changed 5 years ago by Jakub Ś

Keywords: fonts removed
Status: newpending
Version: 4.4.5

Could you please provide me with some code example and plain reproduction steps? Please describe what you do in editor (what you set/paste and where and what you get) to get error or provided reduced sample html file that can be put in samples folder of default editor and will show this problem.

comment:2 Changed 5 years ago by Jakub Ś

@standus any updates?

Issue sounded important for you so I assume you will provide working example soon. I really could speed things up once we know test case where that causes problem for you.

comment:3 Changed 5 years ago by Stan

This is in my config:

    //google fonts
    var initialString = "Audiowide";
    var myFonts = initialString.split("|").sort();
    for(var i = 0; i<myFonts.length; i++){
        config.font_names = config.font_names+';'+myFonts[i];
        myFonts[i] = 'http://fonts.googleapis.com/css?family='+myFonts[i].replace(' ','+');
    }
    config.contentsCss = [config.contentsCss].concat(myFonts);

and when I use it, CKEditor insert into content this: <p><span style="font-family:audiowide">fasdfasdfasd</span></p>

And its bad. CKEditor change Audiowide -> audiowide. When I want use it on frontside Google dont know it, because he is case sensitive.

Last edited 4 years ago by Jakub Ś (previous) (diff)

comment:4 Changed 5 years ago by Stan

Hi, what about this bug?

comment:5 Changed 4 years ago by Jakub Ś

Resolution: duplicate
Status: pendingclosed

I have decided to close this ticket as DUP of #10750 and make the #10750 general ticket for this problem.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy