Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#12509 closed Bug (invalid)

Widget's content menu not shown on widget's editables

Reported by: Matti Järvinen Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: Cc:

Description

Widget contains couple of editables.

When right clicking on widget's editable context menu is not shown. When right clicking non editable part of the widget context menu is shown.

In plugins init definition editor.widgets.add definition init:

this.on( 'contextMenu', function( evt ) {
	evt.data.MyPlugin = CKEDITOR.TRISTATE_OFF;
} );

And in the last lines of plugin init

if ( editor.contextMenu ) 
{
	editor.addMenuGroup( 'MyPlugin' );
	
	editor.addMenuItem( 'MyPlugin', 
		{
			label: editor.lang.MyPlugin.label,
			command: 'MyPlugin',
			group: 'MyPlugin'
		}
	);
}

Change History (2)

comment:1 Changed 4 years ago by Jakub Ś

Resolution: invalid
Status: newclosed

I have consulted this issue just to make sure that it works that way by design.

What you talk about is nested editable area which is based on the same rules as basic editable. Now, editable area can have different elements inside and based on element currently focused, context menu with correct options is shown. Another reason, it works that way, is that once nested widgets are introduced there has to be a way to show context menu for these nested ones. If all of the widget including widget’s editable (which can hold another nested widget) would have same menu there wouldn't be a way to access nested widget.

comment:2 Changed 4 years ago by Matti Järvinen

Ah but of course, had not really thought about that, thanks.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy