Opened 12 years ago

Closed 12 years ago

#1251 closed Bug (invalid)

Internet Explorer ignores right and left margin

Reported by: Jeremy Hein Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: Cc:

Description

In Full Page editing mode, Firefox works as expected, but when I type in values for the left and right margins in Internet Explorer 7, they are completely ignored by the editor. Top and bottom margins show up OK though. I am using FCKeditor 2.4.3 and have tested with the nightly build.

Change History (5)

comment:1 Changed 12 years ago by Alfonso Martínez de Lizarrondo

Keywords: Pending added

I've tested the nightly with IE6 and IE7 and I don't see any problem to set the body margin.

comment:2 Changed 12 years ago by Jeremy Hein

I've tested with both my Windows XP computers one running IE6 and the other running IE7. I go into full page editing mode, I click on Document Properties and then click on the Colors and Margins tab. I then enter 10 for all 4 page margin options (Top, Bottom, Left, and Right.) After I click OK, the source code looks like this:

<!DOCTYPE HTML PUBLIC "-W3CDTD HTML 4.01 TransitionalEN"> <html>

<head>

<title>Full Page Test</title> <meta content="text/html; charset=utf-8" http-equiv="Content-Type" />

</head> <body bottommargin="10" topmargin="10">

<p>This is some <strong>sample text</strong>. You are using <a href="http://www.fckeditor.net/">FCKeditor</a>.</p>

</body>

</html>

As you can see, two of the margin options are missing from the body tag. Again, Firefox works perfect.

comment:3 Changed 12 years ago by Alfonso Martínez de Lizarrondo

Keywords: Confirmed IE added; Pending removed

The problem only happens trying to set those margins to 10 as that is the default value (for top and bottom it's 15), and IE doesn't return back them when serializing the content.

The solution would be to write them using styles instead of those properties that I don't remember if they have been ever allowed.

comment:4 Changed 12 years ago by Jeremy Hein

I see. Well then I guess that's not a bug after all. I try to be careful about submitting bugs as I realize that developers have a lot more to do with their time than look over bug reports. Thanks for all your hard work.

comment:5 Changed 12 years ago by Martin Kou

Keywords: Confirmed IE removed
Resolution: invalid
Status: newclosed

Since IE is only omitting the default value which is visually identical whether absent or present, it should not be a bug.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy