Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#12522 closed Bug (invalid)

CKEditor instance is not properly released on destroy

Reported by: Alain Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: Cc:

Description

Hello,

We get the error "TypeError: Cannot read property 'getEditor' of undefined" when creating a new instance of CKEditor.

Please, see the Word document attached for further details.

Possible related bugs: http://dev.ckeditor.com/ticket/12307 http://dev.ckeditor.com/ticket/12482

Attachments (1)

CKEditor issue with Umbraco.docx (173.2 KB) - added by Alain 5 years ago.
Work document expalining how to reproduce the bug

Download all attachments as: .zip

Change History (7)

Changed 5 years ago by Alain

Work document expalining how to reproduce the bug

comment:1 Changed 5 years ago by Alain

The ticket title is wrong, should be: CKEditor instance is NOT properly released on destroy

comment:2 Changed 5 years ago by Piotrek Koszuliński

Status: newpending
Summary: CKEditor instance is properly released on destroyCKEditor instance is not properly released on destroy
Version: 4.4.5

Hey. Thanks for a very detailed bug report, but unfortunately it does not fulfill one of the very important bug report's requirements - it's not easy to reproduce, because it's not a simplified scenario. I'm really sorry, but we can't spend time reading such long documents, which additionally requires from us debugging some external application.

Besides, the error that you got should have nothing to do with releasing CKEditor instance. It means that CKEditor could not find an element in the DOM for the instance being created. So check whether you use correct IDs.

I'm leaving this ticket open, so please, let us know if you could solve this problem or have a simpler scenario.

comment:3 Changed 5 years ago by Jakub Ś

I will just add that getEditor method is called when inline editor is created.

Are you using inline editor on "Page 2" ? If yes, is textarea present on page or you insert it dynamically perhaps after editor script has been imported and inline method activated?

If that is the case, you should have textarea present when on your HTML page.

comment:4 Changed 5 years ago by Alain

You are right, the textarea control has been destroyed (i still don't know why, probably something to do with angular) but it has nothing to do with CKEditor! So this is NOT a CKEditor bug :)

Thank you very much for your help!!

comment:5 Changed 5 years ago by Piotrek Koszuliński

Resolution: invalid
Status: pendingclosed

comment:6 Changed 5 years ago by Piotrek Koszuliński

Thanks for letting us know.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy