Opened 5 years ago

Closed 4 years ago

#12542 closed Bug (fixed)

Entire page scrolls down briefly if entire editor is not visible in Chrome

Reported by: Martin Vrkljan Owned by:
Priority: Normal Milestone:
Component: General Version: 4.0.1
Keywords: Blink Webkit IBM Cc: satya_minnekanti@…

Description

Reproduced in the demo editor and the nightly build editor.

Take these steps to reproduce:

  • Open a page with an editor in latest Chrome,
  • Resize the editor so that it's either too big to fit on the screen, or position it so the bottom part of the editor is not visible (below the browser window bottom),
  • Position the window scroll so that editor toolbar is fully visible and the bottom is not (as in step 2),
  • Paste some content in,
  • The entire page will quickly jump/flash up and down.

I tried to recreate the same bug in Firefox, but no jump occurred.

Attachments (1)

2014-10-13_1325.swf (1.4 MB) - added by Jakub Ś 5 years ago.

Download all attachments as: .zip

Change History (5)

comment:1 Changed 5 years ago by Jakub Ś

Keywords: Blink Webkit added; scroll chrome jump removed
Status: newconfirmed
Version: 4.4.54.0.1

I was able to reproduce this problem from CKEditor 4.0.1 in Blink and Webkit.

Please see attached video for a way to reproduce but unfortunately video doesn't show page jump (not sure why) which i have observed with my eyes :)

Changed 5 years ago by Jakub Ś

Attachment: 2014-10-13_1325.swf added

comment:2 Changed 4 years ago by Satya Minnekanti

Cc: satya_minnekanti@… added
Keywords: IBM added

comment:3 Changed 4 years ago by Marek Lewandowski

I could no longer reproduce this issue, it could be fixed in 4.5.0 when we introduced custom clipbaord handling. @j.swiderski?

Last edited 4 years ago by Marek Lewandowski (previous) (diff)

comment:4 Changed 4 years ago by Jakub Ś

Resolution: fixed
Status: confirmedclosed

The issue is no longer reproducible starting from CKEditor 4.5.0 beta.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy