Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#12614 closed New Feature (fixed)

Gray out images witch are not fully uploaded

Reported by: Piotr Jasiun Owned by: Piotr Jasiun
Priority: Normal Milestone: CKEditor 4.5.0 Beta
Component: General Version:
Keywords: Cc:

Description

Change opacity of the images witch are not fully uploaded.

Change History (9)

comment:1 Changed 4 years ago by Piotr Jasiun

Status: newconfirmed

comment:2 Changed 4 years ago by Piotr Jasiun

Owner: set to Piotr Jasiun
Status: confirmedreview

Changes in t/12614.

comment:3 Changed 4 years ago by Piotrek Koszuliński

Status: reviewreview_failed

The branch does not exist.

comment:4 Changed 4 years ago by Piotr Jasiun

Status: review_failedreview

Pushed.

comment:5 Changed 4 years ago by Piotrek Koszuliński

Couldn't the style be applied by a stylesheet? Just like we do with e.g. widgets - we use CKEDITOR.addCss and thanks to that one can still override our styling without editing the JS code.

Last edited 4 years ago by Piotrek Koszuliński (previous) (diff)

comment:6 Changed 4 years ago by Piotrek Koszuliński

Status: reviewreview_failed

comment:7 Changed 4 years ago by Piotr Jasiun

Status: review_failedreview

It seems to be a good idea to set class of the every upload widget, so I put the logic of setting class in the upload widget class and add CSS to the upload image. Changes in t/12614b.

comment:8 Changed 4 years ago by Piotrek Koszuliński

Resolution: fixed
Status: reviewclosed

Merged to major with git:2161beb.

I guess you thought about that, but just to be sure - doesn't changing classes conflict with undo manager? And do we need that class at all?

comment:9 Changed 4 years ago by Piotr Jasiun

Undo manager works fine with these changes.

Last edited 4 years ago by Piotr Jasiun (previous) (diff)
Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy