Opened 4 years ago

Closed 4 years ago

#12620 closed Bug (invalid)

Deleting list <li> not possible to catch key event

Reported by: ritesh Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: Cc:

Description

CKEDITOR.plugins.add( 'auditchanges',

{

init: function( editor ) {

editor.addCommand( 'auditchanges',

{

exec : function( editor ) {

}

});

editor.on('key',function(event) { trackModifications(event,false);});

}

});

Open page and insert list into editor Put your cursor before list and press delete (for backspace put your cursor after list and press backspace)

Result: key event isn't caught.

Problem can be reproduced in CKEditor 4.4.1 and 4.4.5

Change History (1)

comment:1 Changed 4 years ago by Piotrek Koszuliński

Resolution: invalid
Status: newclosed
Version: 4.4.5

That's because the event is handled by some other listener before your is executed. Use higher priority or listen to keydown (also with high priority).

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy