Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#12659 closed Bug (invalid)

Cursor stays after ckdetor textarea loses focus

Reported by: Artyom Dmiitriev Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: Cc:

Description

This only happens on Google Chrome, can be reproduced at http://ckeditor.com/demo. When you first click inside the textarea, the cursor starts blinking, then if you click outside the textarea at the moment when the cursor was visible, it does not disappear from the textarea as it should. The result is when the user works with a form which has other inputs apart from a ckeditor textare, she may see 2 cursors at the same time and so get confused.

Change History (3)

comment:1 Changed 5 years ago by Jakub Ś

This is Blink issue and it occurs in both Opera and Chrome.

Please use attached code on HTML5 page:

<div id="testdiv" style="margin:20px; width:500px;">
</div>
<script type="text/javascript">
var iframe = document.createElement( 'iframe' );
iframe.setAttribute( 'width', '500px' );
iframe.setAttribute( 'height', '200px' );
var html = '<!DOCTYPE html><html><title>Cursor Stays</title><head><meta charset="utf-8"></head><body contenteditable="true"><p>Click inside irame and then outside of it when cursor is visible.</p><p>Result: Cursor Satys Visible</p></body></html>';
iframe.setAttribute( 'src', 'data:text/html;charset=utf-8,' + encodeURI(html) );
document.getElementById('testdiv').appendChild(iframe);
</script>

You will get exactly the same result as in CKEditor. This is Blink issue and we will report it to them.

comment:2 Changed 5 years ago by Jakub Ś

Resolution: invalid
Status: newclosed

Since this is browser issue, I'm closing this ticket as invalid.

Link to Blink ticket will be added here for reference however.

comment:3 Changed 5 years ago by Piotrek Koszuliński

I reported this issue on the Blink's bug tracker: https://code.google.com/p/chromium/issues/detail?id=440348

Last edited 5 years ago by Piotrek Koszuliński (previous) (diff)
Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy