Opened 5 years ago

Closed 5 years ago

#12728 closed Bug (invalid)

dialogadvtab absolute Url in Style textbox only in Chrome

Reported by: support-ingenierie Owned by:
Priority: Normal Milestone:
Component: General Version: 4.4.6
Keywords: Cc: lbrouck@…

Description

Hi,

We noticed an anomaly in version 4.4.6 with CKEditor plugin "dialogadvtab".

Environment test: Google Chrome (39.0) CKEditor (4.4.6)

NB: This only happens in Chrome; Firefox or Internet Explorer looks work. In the "dialogadvtab" plugin (not modified )the code to change the url in the "Style" zone relative and not absolute url is not working. Sample code generated in the "Style" zone: background-image: url (http: localhost: 4611 / web / my-picture.jpg); width: 99%; (Google Chrome - incorrect) background-image: url (my-picture.jpg); width: 99%; (Other - correct) Which causes this error message when validates the form "dialog" CKEditor. Can you tell us if this problem is reproducible at home, and if so give us information about unce eventual corrections in the planning date compared to a release. If my description is uncompleted, I can give you more precisions.

Best regards,

Laurent BROUCK

Attachments (3)

img_dialogadvtab_chrome.png (6.1 KB) - added by support-ingenierie 5 years ago.
img_dialogadvtab_chrome2.png (21.0 KB) - added by support-ingenierie 5 years ago.
table.js (33.1 KB) - added by support-ingenierie 5 years ago.
This file is in ~/CKEditor\plugins\table\dialogs

Download all attachments as: .zip

Change History (6)

Changed 5 years ago by support-ingenierie

Attachment: img_dialogadvtab_chrome.png added

Changed 5 years ago by support-ingenierie

comment:1 Changed 5 years ago by Jakub Ś

Keywords: dialogadvtab Chrome Url STyle removed
Status: newpending

I'm having problems understanding this ticket. I thought about two things that might be wrong * relative URL is changed to absolute - no such thing happens in default editor or in demo page http://ckeditor.com/demo;

  • Absolute path is not seen as valid by dialog - I have tried inserting paths starting with http and it is working as expected.

Please provide step by step scenario that shows how to reproduce this issue in demo page or standalone editor (without any customizations or third-party plugins) and please provide a screen-cast.

comment:2 Changed 5 years ago by support-ingenierie

Hi,

Thanks for your answer. In fact, we have create a new plugin "table" witch contains some functionnalities, like put a background in a table. This plugin is quite similar than default plugin table. In this new plugin, there are new tabs (witch are bind with CkFInder) and the "advanced tab" with contains "Style" controls (where there are the mistake describe in the first message). In attachment the file of this plugin. This file should work in your environment.

Laurent BROUCK

Changed 5 years ago by support-ingenierie

Attachment: table.js added

This file is in ~/CKEditor\plugins\table\dialogs

comment:3 Changed 5 years ago by Jakub Ś

Resolution: invalid
Status: pendingclosed

I have checked default editor and it works fine with style entries you have provided.

I have tried checking your file but it hasn't worked. Unfortunately I don't have currently time to review custom changes so please check if this works in default editor and if it does, please start adding your custom changes one by one to see which change is causing this bug (just in case please clear your browser's cache after each change).

If you are able to reproduce this issue in default editor, please provide step by step scenario allowing reproducing it. I will then reopen this issue and in the meantime I have to close it as invalid because I see no CKEditor problem here.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy