Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#128 closed New Feature (duplicate)

Color Code html

Reported by: Adamant22@… Owned by:
Priority: Normal Milestone:
Component: UI : Source View Version:
Keywords: Cc:

Description

I would like to see color coding added to FCKeditor. Specifically, when you view the source html, it would be great if the HTML tags were color coded (e.g., as in Visual Studio or Dreamweaver)!

Change History (3)

comment:1 Changed 12 years ago by Frederico Caldeira Knabben

This is something quite difficult to achieve in a browser environment. The coloring is easy to do. The problem is making it editable.

It would not be a stable solution, as users could easily mangle things by dragging or pasting HTML inside it, and so on. The result would be a nice visual effect, but unusable.

More research is needed in this sense, but I'm not that optimist with it.

comment:2 Changed 12 years ago by adesso

I agree with fred, it is not really a feuture that FCK should provide. I just think of some programs like Dreamweaver and so that moan under the stress of providing color and validation support... I think the main aim for FCK is to be a GUI web editor.

If you want to code HTML in source, use another program...

PS> Just of the top of my head... To make all HTML tags a diffrent color one could use preg_match_all("/(<([\w]+)[>]*>)(.*)(<\/
2>)/", $html, $Amatch); this would give you acces to the HTML tags... but .. nevermind

comment:3 Changed 12 years ago by Alfonso Martínez de Lizarrondo

Component: GeneralUI : Source View
Resolution: duplicate
Status: newclosed

dup of #612

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy