Opened 4 years ago

Closed 4 years ago

#12806 closed New Feature (fixed)

Integrate new get and delete selected HTML methods with drag&drop and paste

Reported by: Piotr Jasiun Owned by: Piotr Jasiun
Priority: Normal Milestone: CKEditor 4.5.0 Beta
Component: General Version:
Keywords: Cc:

Description

Methods inroduced in #11636 should be integrated with clipboard.

Change History (8)

comment:1 Changed 4 years ago by Piotr Jasiun

Status: newconfirmed

comment:2 Changed 4 years ago by Piotr Jasiun

Owner: set to Piotr Jasiun
Status: confirmedassigned

comment:3 Changed 4 years ago by Piotr Jasiun

I changed methods use in clipboard and it turned out that getSelectedHtml change the DOM (what change also the selection). I have added assertions to getSelectedHtml test and this ticket needs to wait until #11586 is done, because it is the reasone of the problem.

comment:4 Changed 4 years ago by Piotrek Koszuliński

We need this closed ASAP because of #12981.

comment:5 Changed 4 years ago by Piotrek Koszuliński

TODO: Remember to revert https://github.com/ckeditor/ckeditor-dev/commit/503667be4d209b732ae878c1384e31b14204061a as soon as this method is not needed.

comment:6 Changed 4 years ago by Piotrek Koszuliński

Blocks #11621.

comment:7 Changed 4 years ago by Piotr Jasiun

Status: assignedreview

Everything seems to work fine. I have pushed changes and some tests to t/12806.

Working on this ticket I met a problem with duplicated ids and reported in to the separate ticket: #13006.

comment:8 Changed 4 years ago by Piotrek Koszuliński

Resolution: fixed
Status: reviewclosed

Great to see it working. I merged the branch to major with git:148553f.

One follow-up ticket for IE8 - #13011.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy