Opened 12 years ago

Closed 12 years ago

#1281 closed Bug (wontfix)

Undo move cursor to the end of the document in IE

Reported by: tba21cn Owned by:
Priority: Normal Milestone:
Component: Core : Undo & Redo Version: SVN (FCKeditor) - Retired
Keywords: Pending Cc:

Description (last modified by Martin Kou)

Test step:

  1. type some content in FCKeditor (multiple paragraphs)
  2. at the end of 1st paragraph, type text, like "abc"
  3. press undo
  4. type "def"

You can find the the "def" appear at the end of the document. IE7 has this issue, FF 2 do not, I am not sure about IE6.

Change History (4)

comment:1 Changed 12 years ago by Martin Kou

Description: modified (diff)
Keywords: Pending added; undo removed

The undo logic of FCKeditor does not save an undo snapshot for every character you typed, because that does not make sense. In fact, for typing actions, it saves an undo step for every 25th character you typed.

While I could easily reproduce the caret jumping phenomenon by repeating your steps. I noticed that the caret jumped to the end because previously I had been typing at final paragraph, and so the caret jumped to where I was typing when it saved an undo snapshot, which is correct. If you have typed, say, 40 random characters to the end of paragraph 1 at step 4, then the caret shouldn't jump to the end. If it does, then it is a bug.

I'm not sure if you're meeting something very different from me (I'm using both IE7 and 6 on the nightly test page). But to me, it seems to be working correctly.

comment:2 Changed 12 years ago by tba21cn

I did some more testing, and I still think it is a bug, and it is not about 25 characters.

The simplest way to tell is: test original test step (in step 2, you can type > 25 characters, and do not type in the last paragraph) in IE, the "def" will ALWAYS show at the bottom of the editor, but if you test using firefox, "def" will NOT show at the bottom of the editor.

If you still do not get my result, I guess I need to test it in some other PCs :P

Thanks!

comment:3 in reply to:  1 Changed 12 years ago by tba21cn

(Maybe I need to reply?)

I did some more testing, and I still think it is a bug, and it is not about 25 characters.

The simplest way to tell is: test original test step (in step 2, you can type > 25 characters, and do not type in the last paragraph) in IE, the "def" will ALWAYS show at the bottom of the editor, but if you test using firefox, "def" will NOT show at the bottom of the editor.

If you still do not get my result, I guess I need to test it in some other PCs :P

Thanks!

Replying to martinkou:

The undo logic of FCKeditor does not save an undo snapshot for every character you typed, because that does not make sense. In fact, for typing actions, it saves an undo step for every 25th character you typed.

While I could easily reproduce the caret jumping phenomenon by repeating your steps. I noticed that the caret jumped to the end because previously I had been typing at final paragraph, and so the caret jumped to where I was typing when it saved an undo snapshot, which is correct. If you have typed, say, 40 random characters to the end of paragraph 1 at step 4, then the caret shouldn't jump to the end. If it does, then it is a bug.

I'm not sure if you're meeting something very different from me (I'm using both IE7 and 6 on the nightly test page). But to me, it seems to be working correctly.

comment:4 Changed 12 years ago by Frederico Caldeira Knabben

Resolution: wontfix
Status: newclosed

I've made some test too, and the current behavior seams to be correct. If I type more than 25 chars, the undo remain in the same paragraph, otherwise it moves to the paragraph 25 characters typed before (at the end of document, at this point).

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy