Opened 5 years ago

Closed 5 years ago

#12840 closed Bug (expired)

ckeditor in ipad safari

Reported by: ioan costescu Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: iOS Cc:

Description

Hi,

I have a problem with ckeditor on ipad. I have the editor in a bootstrap modal. all work well on the other browsers, but on ipad safari, when you touch inside the editor, the keyboard does not appear so you cannot write anything in it. If you hit one of the buttons like bold, the keyboard will appear after a while.

this is how I initialise the ckeditor:

CKEDITOR.replace( 'text_to_add', {

toolbar: [

{ name: 'basicstyles', groups: [ 'basicstyles', 'cleanup' ], items: [ 'Bold', 'Italic', 'Underline', 'Strike'] }, { name: 'paragraph', groups: [ 'list', 'indent'], items: [ 'NumberedList', 'BulletedList', '-', 'Outdent', 'Indent', '-', 'Blockquote'] }, { name: 'links', items: [ 'Link', 'Unlink'] },

{ name: 'styles', items: [ 'Styles', 'Format', 'Font', 'FontSize' ] }, { name: 'colors', items: [ 'TextColor', 'BGColor' ] },

], enterMode: CKEDITOR.ENTER_BR

});

here is an example of the code in this url:

http://svn.dealguardian.com/ck_editor_modal

just hit manage categories and select text box and click continue

thanks

Attachments (1)

test.zip (2.7 MB) - added by ioan costescu 5 years ago.
standalone example

Change History (7)

comment:1 Changed 5 years ago by Piotr Jasiun

I checked on Safari on iPad Air and your configuration seems to work fine if I put the editor on the empty page, however if I follow your link, then the editor does not display at all (while on Chrome everything works fine).

comment:2 Changed 5 years ago by Jakub Ś

Keywords: iOS added
Status: newpending

Ok, so there are two results that imply some problem.

@ionu you have mentioned that you have the editor in a bootstrap modal. Could you perhaps prepare reduced HTML file (with scripts if needed) that can be put on server and will show this problem.
I'm interested in

Could you also tell us which iOS version you use?

Could you also tell us which bootstrap version you use? Perhaps some old version and this issue was fixed in newer one? I'm trying to exclude possibility that perhaps it is bootstrap blocking the keyboard (@pjasun has mentioned that it works ok on empty page).


The below link is a long shot but it mentions problems with bootstrap thus I thought that perhaps you could try it and tell us if it has work for you in your configuration: https://gist.github.com/Reinmar/b9df3f30a05786511a42

comment:3 Changed 5 years ago by ioan costescu

Hi,

the bootstrap is 2.3.2 and the ios version is 8.1.2

I am preparing a stripped version and I will get back with the zip.

thanks

Changed 5 years ago by ioan costescu

Attachment: test.zip added

standalone example

comment:4 Changed 5 years ago by Jakub Ś

Thank you for the sample code. My colleague will have it checked tomorrow.

In the meantime could you tell me if fix mentioned for bootstrap has worked for you? Have you tried it? If not, could you perhaps upgrade your bootstrap version, apply the fix and recheck?

comment:5 Changed 5 years ago by Artur Delura

Hey @ionu, I checked your test.zip and direct page as well on iOS 8.1.3. What I noticed is that editor and keyboard is visible and all functionality work well i.e. I can type into editor. What is strange for me is that cursor is still visible after clicking continue button. Have you noticed the same? Please update your system version and share your thoughts.

comment:6 Changed 5 years ago by Piotrek Koszuliński

Resolution: expired
Status: pendingclosed
Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy