Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#12900 closed Bug (duplicate)

Styling not carried over to empty lines

Reported by: Lynne Kues Owned by:
Priority: Normal Milestone:
Component: Core : Styles Version: 3.0
Keywords: IBM Cc:

Description

Starting with CKEditor demo, ctrl-a/x. Make sure Normal paragraph format is active. Change font to Verdana/14. Type in some text. Press return. Type in some more text. Press arrow-up key. Notice that the font styling is not maintained for the empty paragraph.

Reported by a customer. Expectation is that once font set it should remain active for the entire document.

Change History (3)

comment:1 Changed 5 years ago by Jakub Ś

Status: newconfirmed
Version: 3.0

Styling is carried out to empty lines. You can check this with Firebug for example. You will see something like <p><span style="font-family: comic sans ms, cursive;"></span></p>

The problem is that once you come back to this empty line, cursor is not put inside the span.


We could fix that by putting cursor to span when line is empty. User would see Font Dropdown enabled and if he doesn't want to use this style anymore, he can disable it using that dropdown. The same thing goes for other inline styles that are available in styles dropdown or for basic styles like bold, italic etc.

comment:2 Changed 5 years ago by Lynne Kues

I'm confused by comment1. If I do what is described in the description and then look at the source, I see this:

<p><span style="font-family:comic sans ms,cursive"><span style="font-size:16px">Test 123</span></span></p>

<p>&nbsp;</p>

<p><span style="font-family:comic sans ms,cursive"><span style="font-size:16px">Test</span></span></p>

comment:3 Changed 5 years ago by Jakub Ś

Resolution: duplicate
Status: confirmedclosed

@lynne_kues I was talking about possible fix and not how it works.

I also want to say that I will close this issue as duplicate of #12634. I know your issue has been reported as first but the later one is explained best and is linked to #12633.

Last edited 5 years ago by Jakub Ś (previous) (diff)
Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy