Opened 4 years ago

Closed 4 years ago

#12902 closed Bug (invalid)

FF drop-down menus causing editor to refresh/jump to the top

Reported by: Erin J Snyder Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: Cc:

Description

I'm trying to narrow down if this issue is a problem with my own code, or with the CKEditor, or with Firefox.

The user has enough content in the ckeditor to require scrolling. When the user highlights a piece of text in the ckeditor and changes the color or font of that text using the drop-down menus in the toolbar, the editor refreshes and jumps to the top. This does not happen in Chrome or Safari, only Firefox as far as I can tell.

Non-drop-down buttons and other toolbar items don't have this effect.

No errors print to the console.

I am using Firefox 28.0 and was able to reproduce the behavior on my own project (https://erin.mingle.thoughtworks.com/projects/to_do/cards/89/edit?coming_from_version=2). I could not reproduce it on the demo-page. I'd be happy to give someone from the support team credentials so that they can try to reproduce the issue too.

Thank you!

Attachments (2)

Screen Shot 2015-02-06 at 3.46.00 PM.png (940.7 KB) - added by Erin J Snyder 4 years ago.
Screen Shot 2015-02-06 at 3.46.07 PM.png (808.1 KB) - added by Erin J Snyder 4 years ago.

Download all attachments as: .zip

Change History (7)

Changed 4 years ago by Erin J Snyder

Changed 4 years ago by Erin J Snyder

comment:1 Changed 4 years ago by Jakub Ś

Keywords: firefox drop down removed
Status: newpending
Version: 4.4.5

I can't reproduce this in default CKEditor. It could be something with your CSS that is causing this or old version of FF.

I believe the current version of Firefox is 35.01. First thing you should do is upgrading Firefox, clearing browser's cache and rechecking this issue.

If it still occurs, please provide reduced HTML file that shows this problem. I'm talking about something that can be put into samples folder of default editor and will show the issue.

comment:2 Changed 4 years ago by Erin J Snyder

I upgraded to FF 35.0.1 and cleared cache/cookies/history but am still seeing the behavior.

Our dev team is checking the CSS now. I will update this ticket as soon as I can.

Thank you!

comment:3 Changed 4 years ago by Jakub Ś

If it is possible to prepare reduced HTML file that will show this problem with CKEditor, please provide such file.

comment:4 Changed 4 years ago by Erin J Snyder

We've been unable to reproduce the issue in the CKeditor demo page, and because the behavior is so random (happens 1 out of every 3 - 5 attempts to reproduce) we're not sure if sending an HTML file will help. Our dev team is going to look at our CSS and try to find a root cause. You can close this ticket for now, because I don't think there's anything else you can do. Thanks.

comment:5 Changed 4 years ago by Jakub Ś

Resolution: invalid
Status: pendingclosed

Thank you for the information. I'm closing the ticket for now.

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy