Opened 10 years ago

Closed 10 years ago

#1291 closed Bug (fixed)

IE: List is not created on empty paragraphs

Reported by: Frederico Caldeira Knabben Owned by: Frederico Caldeira Knabben
Priority: Normal Milestone: FCKeditor 2.5 Beta
Component: Core : Lists Version: SVN (FCKeditor) - Retired
Keywords: Confirmed IE Cc:

Description

Steps to Reproduce

  1. Load sample01 with IE;
  2. Hit enter at the end of the text to start a new paragraph;
  3. Create a list.

Nothing will happen. No lists. The same things is valid when selecting two successive empty paragraphs.

Change History (5)

comment:1 Changed 10 years ago by Frederico Caldeira Knabben

Component: GeneralCore : Lists

comment:2 Changed 10 years ago by Martin Kou

Owner: set to Martin Kou
Status: newassigned

comment:3 Changed 10 years ago by Martin Kou

It seems to be a problem with the DOM range iterator.

I used the following code pasted in IE's address bar to watch the DOM range iterator's behavior here:

javascript: void((f=frames[0], w=f.frames[0], r=new f.FCKDomRange(w), r.MoveToSelection(), i=new f.FCKDomRangeIterator(r))); void(fn=function(){while(b=i.GetNextParagraph())alert(b.tagName);}); void(fn());

Say, if you have selected three paragraphs, and you executed the above JavaScript code in the address bar, you should see three message boxes telling you of the paragraphs' node names.

But what I've observed in IE is this...

  1. If I selected three empty paragraphs, I see no message boxes - the DOM range iterator never got anything.
  2. If I selected a non-empty paragraph and one empty paragraph after that, with some empty or non-empty paragraphs after that and not selected. The iterator would run over all paragraphs in the document, selected or not selected.

It seems to me the range iterator is not handling empty blocks correctly right now.

comment:4 Changed 10 years ago by Frederico Caldeira Knabben

Owner: changed from Martin Kou to Frederico Caldeira Knabben
Status: assignednew

comment:5 Changed 10 years ago by Frederico Caldeira Knabben

Resolution: fixed
Status: newclosed

Fixed with [906]. Click here for more info about our SVN system.

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy