Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#12927 closed Bug (invalid)

Widget plugin makes Chromium crash with 2 blank lines at the start

Reported by: Lyuba Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: Cc:

Description

This is something our team ran into using Chromium during development. It doesn't appear to affect production, but filing anyway just in case.

Steps to reproduce:

  1. Launch the attached index.html (which includes the minimal code to reproduce the bug).
  2. In the toolbar, click the button next to the image button (button has no icon, its tooltip says 'Create widget').
  3. Click the editor to grab focus, and press Ctrl + Home to move the caret to the very beginning (though it might be invisible).
  4. Now press the Enter key twice.
  5. See that Chromium crashes.

This is observed using Chromium Version 38.0.2125.0 (292384) (64-bit)

Attachments (1)

index.html (1.0 KB) - added by Lyuba 4 years ago.
Minimum code to reproduce

Download all attachments as: .zip

Change History (5)

Changed 4 years ago by Lyuba

Attachment: index.html added

Minimum code to reproduce

comment:1 Changed 4 years ago by Jakub Ś

Status: newpending

I have tried reproducing this quite a few times but couldn't.

Issue you have reported sounds however serious as editor should not crash the browser. Could you:

  1. Check if this issue occurs on Chromium 40. The current version for this browser is 40.
  2. Provide a screen case for this issue?
  3. Tell me which Operating System you use? I have tried Ubuntu 1404 - both 64 and 32 bit.

comment:2 Changed 4 years ago by Lyuba

Actually, it looks like this only occurs on Dartium, downloaded from https://www.dartlang.org/tools/download.html

I thought I had reproduced it on plain Chromium, but I can't now. The Dartium version is still 38 and crashes consistently. Sometimes it even crashes immediately when I focus in the editor after inserting the widget.

The browser just shows the standard "Aw, Snap!" page when it crashes.

I'm using Ubuntu 14.04 64-bit

comment:3 Changed 4 years ago by Jakub Ś

Resolution: invalid
Status: pendingclosed

Thank you for the information however I will have to close this issue as invalid. There are two reasons for that:

  1. CKEditor works with standard Chromium browser
  2. When you look at https://www.dartlang.org/tools/dartium/, first thing you see is a warning saying that this browser is not stable.

If editor works with standard browser but doesn't with customized one then perhaps this should be reported to Dartium Team. This doesn't have to be the only JS application that breaks Dartium and this might be more general problem on their side.

comment:4 Changed 4 years ago by Lyuba

Sounds good, thanks for looking into it.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy