Opened 4 years ago

Closed 4 years ago

#12996 closed Bug (fixed)

SCAYT Affecting Dialog Double Click

Reported by: Lee Owned by:
Priority: Normal Milestone:
Component: UI : Spell Checker Version: 4.4.0
Keywords: Firefox IE Cc:

Description

Follow the steps to reproduce:

  1. Make sure you have set the scayt_autoStartup

configuration option to true

  1. Enter some text and click enter
  2. Now add either an image or flash movie, enter any url and click "OK"
  3. Now double click on the image or flash movie and notice the values are empty. The onShow function within the dialog says that no value is selected.

Change History (12)

comment:1 Changed 4 years ago by Jakub Ś

Keywords: Firefox IE added
Status: newconfirmed
Version: 4.4.74.4.0

Problem can be reproduced from CKEditor 4.4 in all browsers.

Last edited 4 years ago by Jakub Ś (previous) (diff)

comment:2 Changed 4 years ago by TimH

Any progress on this? As I too am seeing the same issue and have had to disable the spell check to get around it which is less than ideal for poor people like me who can't spell.

comment:3 Changed 4 years ago by Jakub Ś

This is SCAYT issue. I have reported it to SCAYT team: https://github.com/WebSpellChecker/ckeditor-plugin-scayt/issues/98.

comment:4 Changed 4 years ago by TimH

I can see from the SCAYT team that they have fixed the issue their end. Any timeframe on this being carried through to CKEditor?

comment:5 Changed 4 years ago by Jakub Ś

Usually it looks like this that after SCAYT updates their version we introduce this version in CKEditor provided that there are no critical issues in terms of cooperation between SCAYT and the editor.

Unfortunately we have found nasty issue which is currently a blocker https://github.com/WebSpellChecker/ckeditor-plugin-scayt/issues/108 that prevents us from upgrading.

Once this issue is fixed we will be more than happy to upgrade SCAYT in the editor.

comment:6 Changed 4 years ago by TimH

Thanks for the update. Hopefully we should have this resolved soon.

comment:7 Changed 4 years ago by TimH

Can you confirm if this was resolved in 4.5.5?

comment:8 Changed 4 years ago by Jakub Ś

Status: confirmedpending

First of all we haven't upgraded the Scayt in CKEditor 4.5.5 but we will most likely do it in 4.4.6.

Now, to answer your question. We (2 people) have tried reproducing this issue in 4.5.5 and couldn't. Sounds good but the problem is that we couldn't also reproduce it in older versions. Are you able to reproduce it? Perhaps there is some other test case that you know?

comment:9 Changed 4 years ago by TimH

Just checking the first line of your post that you actually meant:

First of all we haven't upgraded the Scayt in CKEditor 4.5.5 but we will most likely do it in 4.5.6. (not 4.4.6)

Your post on the 3rd of March says that you were able to reproduce it on 4.4 on all browsers and I would presume that included the old version of Scayt that would have been shipped with that version of ckeditor. So not sure why the same setup would now not work.

The main issue for us is that we have created a range of custom plugins and thus with spell check enabled every time you double clicked it - it lost the values hence we have had to disable the spell check as the lesser of two evils. This is not going to give you a test case though your end.

I would suggest that if you are not able to replicate still your end that as Scayt is fixed and pushed through to next release that we then grab that copy and come back to you to let you know if our custom plugins are ok. That way the ticket can then be closed.

comment:10 Changed 4 years ago by Jakub Ś

So not sure why the same setup would now not work.

That makes us both to be honest. I'm not sure why I can't reproduce the issue now.

fixed and pushed through to next release that we then grab that copy and come back to you to let you know if our custom plugins are ok. That way the ticket can then be closed.

Sounds good. I will be waiting for your feedback.

Please also note that we haven't decided to update the SCAYT because of few new issues we have found with that version.

comment:11 Changed 4 years ago by TimH

This ticket can be closed. We updated our Editor here and no longer have this issue.

Thank you.

comment:12 Changed 4 years ago by Jakub Ś

Resolution: fixed
Status: pendingclosed
Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy