Opened 4 years ago

Closed 4 years ago

#13015 closed Bug (fixed)

Dropping image on image in editor causes page reload

Reported by: Jakub Ś Owned by: Artur Delura
Priority: Must have (possibly next milestone) Milestone: CKEditor 4.5.0
Component: General Version: 4.5.0 Beta
Keywords: Cc:

Description

Try dropping image on image in editor and page will relaod

Change History (12)

comment:1 Changed 4 years ago by Jakub Ś

Status: newconfirmed

comment:2 Changed 4 years ago by Piotrek Koszuliński

Version: 4.5.0 (GitHub - major)

comment:3 Changed 4 years ago by Piotrek Koszuliński

I can only reproduce this with the image2 plugin, not with the image one.

See e.g.:

comment:4 Changed 4 years ago by Piotrek Koszuliński

Summary: Dropping image on image in editor causes page relaodDropping image on image in editor causes page reload

comment:5 Changed 4 years ago by Piotrek Koszuliński

Milestone: CKEditor 4.5.0 BetaCKEditor 4.5.0

comment:6 Changed 4 years ago by Artur Delura

Priority: NormalHigh

comment:7 Changed 4 years ago by Artur Delura

Owner: set to Artur Delura
Status: confirmedassigned

comment:8 Changed 4 years ago by Artur Delura

The problem was caused because drop event is not fired on contenteditable=false which is case on image2 plugin.

To make this happend - default browser action has been prevented in dragover event callback on widget wrapper element.

The curious fact is that such event is fired in Firefox.

Remaining problem is that now browser page is not reloaded, but image is uploaded nowhere.

comment:9 Changed 4 years ago by Artur Delura

In the following situation we have to options. One is to prevent totally uploading images if drop is on elment which is cE=false or descendant.

The second solution is to move drop range right after first not editable boundary element.

Both options will be called, when drop target is noneditable.

comment:10 Changed 4 years ago by Piotrek Koszuliński

In the following situation we have to options. One is to prevent totally uploading images if drop is on elment which is cE=false or descendant.

Drop on a non-editable element should be cancelled. I consider such drop as invalid.

The curious fact is that such event is fired in Firefox.

What's curious about the fact that such event is fired on Firefox? Or did you mean that it isn't fired?

Did you check whether dropping inside nested editable still works when dragover is cancelled on widget wrapper?

comment:11 Changed 4 years ago by Artur Delura

Status: assignedreview

Drop on a non-editable element should be cancelled. I consider such drop as invalid.

I implemented this that way, but now it is inconsistent with image plugin.

What's curious about the fact that such event is fired on Firefox? Or did you mean that it isn't fired?

Sorry, I meant that it's funny that it works only on FF. I didn't checked specification, but it seems logical there.

Did you check whether dropping inside nested editable still works when dragover is cancelled on widget wrapper?

I checked image2 with caption and dragging and droping text works properly there.

Changes in branch:t/13015.

comment:12 Changed 4 years ago by Piotrek Koszuliński

Resolution: fixed
Status: reviewclosed

Fixed on major with git:cb5fd3a.

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy