Opened 5 years ago

Closed 5 years ago

#13093 closed Bug (fixed)

[Webkit/Blink] Paste From Word's conflict with the paste filter

Reported by: Piotrek Koszuliński Owned by: Piotrek Koszuliński
Priority: Must have (possibly next milestone) Milestone: CKEditor 4.5.0 Beta
Component: General Version: 4.5.0 Beta
Keywords: Cc:

Description

On Webkit and Blink paste filter is set to semantic-content by default.

It means that every external paste will be stripped from classes and styles. And this means that PFW's options like PFWKeepStyles stop working.

We could require adjusting paste filter's options with code like:

editor.on( 'instanceReady', function( evt ) {
    if ( editor.pasteFilter )
        editor.pasteFilter.allow( '*(*)[*]' );
} );

But this basically disables the paste filter which we need on Webkit and Blink for external pasting due to the awful mess that these browsers do in HTML.

So the only solution I can think of now is to disable the paste filter if PFW was executed for that paste.

Change History (7)

comment:1 Changed 5 years ago by Piotrek Koszuliński

We initially had this problem in #12256.

comment:2 Changed 5 years ago by Piotr Jasiun

It makes some sense. For pasting content from Word, pasteFromWord plugin is the filter and the second filtering is no needed.

comment:3 Changed 5 years ago by Jakub Ś

Status: newconfirmed

comment:4 Changed 5 years ago by Piotrek Koszuliński

Priority: NormalHigh

comment:5 Changed 5 years ago by Piotrek Koszuliński

Owner: set to Piotrek Koszuliński
Status: confirmedassigned

comment:6 Changed 5 years ago by Piotrek Koszuliński

Status: assignedreview

I pushed branch:t/13093.

comment:7 Changed 5 years ago by Piotr Jasiun

Resolution: fixed
Status: reviewclosed

Closed with git:0c92f25.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy