Opened 5 years ago

Closed 5 years ago

#13099 closed Bug (invalid)

Adding 11 or more CKEditors issue with IE9 browser

Reported by: Raghu Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: Cc: ejsatterwhite@…, vmiller@…

Description

Hi CKSource Team,

We have integrated the latest version of CKEditor (Version 4.4.7) to our website.

When we try adding CKEditors in our webpage (using a "Add Response" button), after adding 11 or above CKEditors then some of the CKEditors are loading within other CKEditors and the newly added CKEditor space is just empty space. This is occurring in IE9 browser.

This issue was also occurring with the older version of CKEditor 4.0.1.

It works perfectly in IE11, Chrome and Safari browsers without any issues.

Only in IE9 browser we are getting this issue.

Attached screen captures of the issue.

Any help would be appreciated.

Thanks, Raghu.

Attachments (3)

CKEditor_IE9_Issue-32615.jpg (206.2 KB) - added by Raghu 5 years ago.
CKEditor_IE9_Issue2-32615.jpg (155.4 KB) - added by Raghu 5 years ago.
Error screen capture 2
sample.html (4.3 KB) - added by Raghu 5 years ago.
sample html file

Download all attachments as: .zip

Change History (8)

Changed 5 years ago by Raghu

Changed 5 years ago by Raghu

Error screen capture 2

comment:1 Changed 5 years ago by Piotrek Koszuliński

Keywords: CKEditors with IE9 browser removed
Status: newpending
Version: 4.4.7

Why do you think that it's a bug in CKEditor? From the description that you provide it seems that it may be something related to the way how you created editors.

In any case - to be able to confirm a bug we need to be able to reproduce, therefore a minimal sample is required.

comment:2 Changed 5 years ago by Raghu

Hello Reinmar,

Please access the following demo URL for reproducing the issue:

http://98.191.170.249:8080/TestItemBankTab_StageAdmin

Please use IE9 browser for reproducing the issue.

Step-1: Login with User ID "888" and Password as "password".

Step-2: After successful login the "Test Item Search" page is displayed, in this page please click on "Insert New Test Item" button that will take to "Test Item Modification" page.

Step-3: In the "Test Item Modification" please change the "Test Item Type:" label drop down value to "Drap and Drop".

Step-4: If we scroll down a little, there is a "Add Response" button is displayed in the page.

Step-5: Below to the "Add Response" button, there are already 4 CKEditors are displayed in the page by default. And if we start clicking on "Add Response" button then the new additional CKEditors keep adding to the bottom of the page. After clicking on "Add Response" button for 6 times and then from the 7th time onwards if we keep scrolling down the page and observe the CKEditors adding at the bottom of the page then we can see this issue. Along with the existing 4 CKEditors in the page, we can add 12 more CKEditors (a total of 16) as responses in the page and can see the issue occurring.

Thanks, Raghu.

comment:3 Changed 5 years ago by Piotrek Koszuliński

This is not a minimal sample that I asked for. We cannot debug your system. Please create a sample that directly shows that the issue is caused by CKEditor. Otherwise, we'll be forced to close this ticket.

comment:4 Changed 5 years ago by Raghu

Hello Reinmar,

I have created the attached sample html file with our customized CKEditor as per your request.

The customize CKEditor integrated in the sample html file is loading all the 20 CKEditors properly and working in IE9 browser.

We have found out that the issue is only occurring when the customized CKEditor is integrated with our code and loading in IE9 browser.

Can you suggest any solution for this as the customized CKEditor when integrated with our code is working properly in other browsers but not in IE9 browser.

Regards, Raghu.

Changed 5 years ago by Raghu

Attachment: sample.html added

sample html file

comment:5 Changed 5 years ago by Piotrek Koszuliński

Resolution: invalid
Status: pendingclosed

We have found out that the issue is only occurring when the customized CKEditor is integrated with our code and loading in IE9 browser.

Can you suggest any solution for this as the customized CKEditor when integrated with our code is working properly in other browsers but not in IE9 browser.

Every browser is different, what means that you need to debug this issue on IE9 to see what's happening.

I'm closing this issue for now. If you'll find that this issue in your system is caused by CKEditor please let us know, so we'll reopen the ticket.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy