Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#13150 closed Bug (duplicate)

Preview not working in Firefox

Reported by: lokesh2206 Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: Cc:

Description (last modified by Piotrek Koszuliński)

Preview click in firefox show empty screen, whereas it works perfectly in google chrome and other browsers.

Note: It works when ckeditor.js is loaded from the same domain, but not on http://ckeditor.com/demo#full for instance where ckeditor.js is loaded from the CDN.

Attachments (1)

Screenshot from 2015-04-08 13:07:03.png (97.1 KB) - added by lokesh2206 5 years ago.

Download all attachments as: .zip

Change History (10)

Changed 5 years ago by lokesh2206

comment:1 Changed 5 years ago by Piotrek Koszuliński

Status: newpending

It works for me on the latest Firefox (37.0.1) and I remember that it worked for previous versions too. Could you anyway, check the latest version of Firefox? And how do you test it? Is it reproducible on http://ckeditor.com/demo?

comment:2 Changed 5 years ago by lokesh2206

Yes it is reproducible on ckeditor demo, select full featured ckedior.

comment:3 Changed 5 years ago by Piotrek Koszuliński

I asked you to check on http://ckeditor.com/demo, but I haven't checked it myself. And it does not work for me there too. It does work on my local machine though. Strange...

comment:4 Changed 5 years ago by Piotrek Koszuliński

Status: pendingconfirmed

comment:5 Changed 5 years ago by Piotrek Koszuliński

Description: modified (diff)
Summary: Preview not working in firefox(Version 31.0)Preview not working in Firefox

comment:6 Changed 5 years ago by Piotrek Koszuliński

Description: modified (diff)

I checked that the preview does not work if ckeditor.js is loaded from a different domain (e.g. CDN)

comment:7 Changed 5 years ago by Jakub Ś

I can't remember now how it has worked in previous versions of Firefox but currently I can see this in URL: http://cdn.ckeditor.com/4.4.7/standard-all/plugins/preview/preview.html?t=F0RD and this error when page loads:

Error: Permission denied to access property '_cke_htmlToLoad'
Code: if ( typeof window.opener._cke_htmlToLoad == 'string' )

comment:8 Changed 5 years ago by Wiktor Walc

Resolution: duplicate
Status: confirmedclosed

Duplicate of #12979

comment:9 Changed 5 years ago by lokesh2206

Thank you Reinmar. I checked it was from different domain. Also I have tried solution http://ckeditor.com/forums/Plugins/Plugin-preview , still not working.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy