Opened 4 years ago

Closed 4 years ago

Last modified 3 years ago

#13153 closed Bug (duplicate)

Pasting lists from Word: custom text indentation and numbered list markers

Reported by: Christophe Guillou Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: IBM Cc:

Description

This issue was raised by one of IBM main customer, who is experiencing difficulty copy/pasting numbered list from word.

Attached is an example of what is what the user experiences with the latest CKEditor, versus word / another web editor.

Attachments (1)

CKEditor comparison list feature.jpg (298.0 KB) - added by Christophe Guillou 4 years ago.

Download all attachments as: .zip

Change History (5)

Changed 4 years ago by Christophe Guillou

comment:1 Changed 4 years ago by Christophe Guillou

Is there anyway the pastefromword plugin could preserve numbering / identation ?

comment:2 Changed 4 years ago by Jakub Ś

Resolution: duplicate
Status: newclosed

Indentation - from what I can see editor works nice and indents lists. This second editor most likely sees those lists as paragraphs, thus it doesn't keep indentation.

Numbering - #8516. Unfortunately this is something that is not available in HTML by default. You would need to use CSS for it but there is also a problem how browsers see this code. In Chrome and FF there are 1.1.1 so perhaps some feature that includes changes in pastefromword filter plus CSS application could be implemented in the future. The problem is IE which converts Word lists into beautiful HTML lists so (since there is no such numbering in HTML) the 1.1.1 numbers are gone and there is no way for editor to know that number was 1.1.1 and not 1.

I'm closing this one as duplicate of #8516.

comment:3 Changed 3 years ago by Anna Tomanek

Summary: Copy/ Paste Numbered List from word documentCopy / Paste Numbered List from a Word document

comment:4 Changed 3 years ago by Anna Tomanek

Summary: Copy / Paste Numbered List from a Word documentPasting lists from Word: custom text indentation and numbered list markers
Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy