Opened 4 years ago

Closed 3 years ago

#13164 closed Bug (fixed)

Form Plugin - Error on Insert Hidden Filed

Reported by: Bernd Bäumler Owned by:
Priority: Normal Milestone: CKEditor 4.4.8
Component: General Version: 4.4.7
Keywords: Cc:

Description

Hi,

There is an error on http://nightly.ckeditor.com/15-04-11-06-09/full/samples/plugins/toolbar/toolbar.html if you try to insert a hidden field clicking "Hidden field", entering values for name and value and press "ok", a js error occurs:

TypeError: a.setAttribute is not a function

a.setAttribute( 'type', 'hidden' );

This happens on Firefox 37.01, Chrome and Safari, IE 11 works fine

Best regards

Bernd

Change History (6)

comment:1 Changed 4 years ago by Bernd Bäumler

should read: only IE 11 works fine

comment:2 Changed 4 years ago by Jakub Ś

Keywords: firefox added; Form removed
Status: newconfirmed
Version: 4.4.8 (GitHub - master)4.4.7

Looks like Recent regression as it can be reproduced from CKEditor 4.4.7 in FF only

comment:3 Changed 4 years ago by Piotrek Koszuliński

Milestone: CKEditor 4.4.8

Confirmed. Must have been this commit: https://github.com/ckeditor/ckeditor-dev/commit/4c8bc325853862a1f4319ad745b59b23970a7796#diff-a567911afd952426bdde87a17ff441b6L29. Reverting it should be a quick workaround.

We'll fix this in 4.4.8.

comment:4 Changed 3 years ago by Jakub Ś

#13223 was marked as duplicate.

comment:5 Changed 3 years ago by Piotrek Koszuliński

Summary: Form Plugin - Error on Insert Hidden Filed on Firefox 37.01Form Plugin - Error on Insert Hidden Filed

comment:6 Changed 3 years ago by Piotrek Koszuliński

Keywords: firefox removed
Resolution: fixed
Status: confirmedclosed

Fixed on master with git:ced0327.

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy