Opened 3 years ago

Closed 3 years ago

#13176 closed Bug (fixed)

[IE8] Errors while DnD of widgets in the embed widget tests

Reported by: Piotrek Koszuliński Owned by: Tade0
Priority: Normal Milestone:
Component: General Version: 4.5.0 Beta
Keywords: Cc:

Description

  1. Open http://tests.ckeditor.dev:1030/tests/plugins/embed/manual/embed
  2. Try DnD.
  3. Error: Object doesn't support this property or method
				// Don't visit non-editable internals, for example widget's
				// guts (above wrapper, below nested). Still check editable limits,
				// as they are siblings with editable contents.
				if ( !el.hasAttribute( 'contenteditable' ) && el.isReadOnly() )
					continue;

Which means that "el" is something weird.

Change History (7)

comment:1 Changed 3 years ago by Piotrek Koszuliński

Funny fact is that this issue is reproducible only in that test file. It works fine with code snippets, embedsemantic, image2. If this turns out to be hard to fix, we should check if it's reproducible outside the test, on a real web page. It may not be worth to fight this.

comment:2 Changed 3 years ago by Piotrek Koszuliński

Status: newconfirmed

comment:3 Changed 3 years ago by Jakub Ś

It seems it is enough to click on grab handle and error pops out.

comment:4 Changed 3 years ago by Piotrek Koszuliński

Milestone: CKEditor 4.5.0CKEditor 4.5.1

comment:5 Changed 3 years ago by Tade0

Owner: set to Tade0
Status: confirmedassigned

comment:6 Changed 3 years ago by Tade0

Could you describe what kind of drag and drop specifically causes this error?

comment:7 Changed 3 years ago by Piotrek Koszuliński

Milestone: CKEditor 4.5.1
Resolution: fixed
Status: assignedclosed

This issue isn't reproducible any more. Earlier it was enough to click the drag handle and error pops out.

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy