Opened 4 years ago

Closed 2 years ago

#13180 closed Bug (invalid)

FF: Cursor stops before non content editable element when pressing left arrow key

Reported by: Inga Owned by:
Priority: Normal Milestone:
Component: General Version: 3.3
Keywords: Firefox Cc: Satya Minnekanti

Description (last modified by Jakub Ś)

Steps to reproduce:

  1. Go to http://ckeditor.swg.usma.ibm.com/
  2. In the console: CKEDITOR.instances.editor1.insertHtml('aaa <a contenteditable="false" href="www.ibm.com">@Amy Jones126</a> aaa')
  1. Same for a similar structure more similar to mentions
  2. In the console: CKEDITOR.instances.editor1.insertHtml('aaa <span contenteditable="false"><a href="www.ibm.com">@Amy Jones126</a></span> aaa')
  3. Press the left arrow key...

Change History (5)

comment:1 Changed 4 years ago by Jakub Ś

Description: modified (diff)

comment:2 Changed 4 years ago by Jakub Ś

Keywords: Firefox added
Status: newconfirmed
Version: 4.4.73.3

The best way to reproduce this problem is using below code:

var editor = CKEDITOR.replace( 'editor1', { allowedContent:true } );
editor.on( "instanceReady", function( event ){
editor.setData('', function(){
	editor.insertHtml('aaa <a contenteditable="false" href="www.ibm.com">@Amy Jones126</a> aaa');
	} );
});
  1. The problem is that same or similar thing happens in native contenteditable field. Cursor is also gone there.
  2. In CKEditor 3.0 - 3.2.2 it was possible to move cursor around the link but it was also possible to modify it.
  3. Starting from CKEditor 3.3 it is no longer possible to modify contenteditble="flase" elements but it is also not possible to freely move cursor around them.

I'm confirming this issue as perhaps there might be something done to "put cursor next to non-editable element, focus it and again put cursor next to it" when using arrows

comment:3 Changed 4 years ago by Piotrek Koszuliński

Status: confirmedpending

Does it happen with widgets too? Non-editable elements are supported only in form of widgets.

comment:4 Changed 4 years ago by Jakub Ś

No the widgets are handled nicely - you can move around with arrow as much as you like.

comment:5 Changed 2 years ago by Jakub Ś

Resolution: invalid
Status: pendingclosed

Non-editable elements are supported only in form of widgets.

Thank you for clarification @Reinmar. I'm closing the ticket.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy