Opened 3 years ago

Closed 3 years ago

#13199 closed Bug (fixed)

Embedsemantic does not support widget classes

Reported by: Piotrek Koszuliński Owned by: Olek Nowodziński
Priority: Must have (possibly next milestone) Milestone: CKEditor 4.5.0
Component: General Version: 4.5.0 Beta
Keywords: Cc:

Description

Classes are neither read nor printed to the source.

The embed plugin should be reviewed as well.

Change History (6)

comment:1 Changed 3 years ago by Piotrek Koszuliński

Priority: NormalHigh
Status: newconfirmed

comment:2 Changed 3 years ago by Olek Nowodziński

Owner: set to Olek Nowodziński
Status: confirmedassigned

comment:3 Changed 3 years ago by Olek Nowodziński

Status: assignedreview

branch:t/13199

  • Added widget class tests for
    • embed
    • embedsemantic
  • Fixed non-transferrable classes in embedsemantic.

comment:4 Changed 3 years ago by Piotrek Koszuliński

Resolution: fixed
Status: reviewclosed

I was able to simplify the way how classes are copied to the downcasted element.

Fixed on major with git:d31d1be.

comment:5 Changed 3 years ago by Piotrek Koszuliński

Resolution: fixed
Status: closedreopened

Turns out we were close to a disaster with this one. We totally forgot that widget styles must be registered in the filter and for that a special properties styleableElements or styleToAllowedContentRules must be set. We didn't catch this, because this worked well in the embed widget because the whole div[data-oembed-url] is skipped by the filter. But it didn't work at all with embedsemantic, so classes were still filtered out.

comment:6 Changed 3 years ago by Piotrek Koszuliński

Resolution: fixed
Status: reopenedclosed

Fixed on major with git:251f830.

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy