Opened 5 years ago

Closed 5 years ago

#13203 closed Bug (invalid)

Aborting upload doesn't really abort

Reported by: Artur Delura Owned by:
Priority: Normal Milestone:
Component: General Version: 4.5.0 Beta
Keywords: Cc:

Description (last modified by Artur Delura)

To reproduce this issue, you have to have properly setup CKFinder with CKEditor. Also you should add some sleep in connector to be available to abort uploading before it's done by server.

  1. Open sample http://ckeditor.dev/plugins/uploadwidget/dev/upload.html
  2. D&D some image to initiate uploading.
  3. Delete an image before uploading is done.

There should be an information visible that uploading was aborted by the user.

Unexpected Result: image has been physically uploaded to the server.

What I found is that abort in XHR is called synchromously when progress comes from the server. If file is relatively small, then there is no progress called until file is fully loaded.

Change History (3)

comment:1 Changed 5 years ago by Artur Delura

Description: modified (diff)

comment:2 Changed 5 years ago by Piotrek Koszuliński

I'm not sure that expected behaviour should be that it will not be uploaded. That could lead to issues - e.g. when you cut this dropped image and paste it in other location. So, in my opinion, deleting the image should not abort uploading.

However, there should be a way to abort uploading, because user might have dropped some a wrong file or something. But first of all - we need to confirm with PJ what's doable.

comment:3 Changed 5 years ago by Piotr Jasiun

Resolution: invalid
Status: newclosed

Every time the progress event occurred editor check if there is an instance of the proper upload widget and if not the upload process is aborted. This is because we do not want to stop the upload if the upload widget was moved.

When you upload small file the only progress event you get is 100% progress, when the file is uploaded so operation will be aborted after the upload. Sleep does not simulate the real case here when we upload a big file and get many progress events, so this issue is forced by the unreal upload simulation.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy