Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#13259 closed New Feature (duplicate)

Feature request: When toggling to source mode, place cursor at same place as in WYSIWYG mode

Reported by: Moini Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: Cc:

Description

Hi,

I would very much like to see this feature in ckeditor, especially for working on long texts.

It can sometimes take a long time to find the correct position to continue editing when toggling to source mode. Automatically placing the cursor at the current position from WYSIWYG mode and scrolling to that position would be extremely helpful.

And one other thing I'd like to tell you:

Your bug reporting tool is very difficult to access and use, I'll give some of the reasons below.

  • For one, if you forgot user name and password, you cannot get back your account, as resetting the password does require the user name. So if one forgets both, the only thing one can do is use a different mail address... Mail address only should be sufficient for this.
  • To register, there are fields marked as 'optional'. If you don't enter anything there, you get an error message that those are required. The fields should be clearly marked as to their required-ness.
  • To find if a bug was already reported, you need to go through a list of several hundreds of bugs. I can't do that, I'm sorry if this has already been reported, but I really do not have the time to read through more than 13 pages of bug report titles. I think this could be some kind of vicious circle - users report more bugs, because they cannot see if theirs has already been reported. I don't know a solution for this...
  • There is no real simple bug report list. The only access to bug reports seems to be the search box. This makes it difficult to browse bugs, or to even find *where* to browse bugs.
  • It isn't really clear that the search box is for searching bug reports.

CKEditor is a great tool, though, which I like to use - and I thank you for all your work on it!

Change History (2)

comment:1 Changed 4 years ago by Jakub Ś

Resolution: duplicate
Status: newclosed

This issue is a duplicate of #3709.

We don't plan to work on this feature on our own so the add-on mentioned in #3709 will have to do.

comment:2 Changed 4 years ago by Moini

Thank you for the link :D

I hope I can find out how to integrate this plugin with django-cms-ckeditor...

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy