Opened 12 years ago

Closed 12 years ago

#1327 closed Bug (fixed)

FCKEditor+Mediawiki munges media: links

Reported by: Lane Owned by:
Priority: Normal Milestone:
Component: Project : MediaWiki+FCKeditor Version:
Keywords: Cc:

Description

FCKEditor integrated into mediawiki appears to be munging the media links when trying to link to an uploaded file, such that

[[media:filename.pdf]]

becomes

media:filename.pdf?

This is happening with Firefox 2.0.0.7 and IE6.

Change History (6)

comment:1 Changed 12 years ago by Lane

More info: the editor appears to be assuming at first save that the file doesn't exist, even if it does. After using the special:upload page once on an article, it is changed to a functional link: http://servername.com/wiki/sandbox/images/e/e5/filename.pdf

comment:2 Changed 12 years ago by Wiktor Walc

Resolution: fixed
Status: newclosed

Fixed with [949].

Please download the latest SVN version and let us know whether problem still exists.

comment:3 Changed 12 years ago by Lane

Resolution: fixed
Status: closedreopened

I downloaded rev 950, and I can confirm it works in IE6. It looks like this now has become an issue with Firefox. In Firefox 2.0.0.7, it's close, but not quite fixed:

[[media:filename.pdf]]

becomes

media:filename.pdf?

Whereas in IE6, you have: [[media:filename.pdf|media:filename.pdf]]

which works well.

Also of note: in Firefox, any underscores in the filename are changed to spaces, thusly:

[[media:filename_with_underscores.pdf]]

becomes

media:filename_with_underscores.pdf?

comment:4 Changed 12 years ago by Wiktor Walc

Thanks for quick reply. How about now? [951]

comment:5 Changed 12 years ago by Lane

Well done! Thanks for the quick fix! -Lane

comment:6 Changed 12 years ago by Wiktor Walc

Resolution: fixed
Status: reopenedclosed

I'm glad it worked :)

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy